Katalog CVE

CVE-2026-105612

NiskieCVSS 3.5
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.17%

Percentyl 6 - wyżej niż 6% wszystkich znanych CVE

Streszczenie

PostgreSQL Anonymizer zawiera podatność pozwalającą obejść ograniczenie tylko-do-odczytu ról zamaskowanych za pomocą CTE modyfikujących dane. Problem został rozwiązany w wersji 3.3.0 i nowszych.

Ocena ryzyka

Zamaskowana rola może modyfikować dane, mimo że powinna mieć tylko dostęp do odczytu, co narusza integralność danych.

Rekomendacja

Zaktualizuj PostgreSQL Anonymizer do wersji 3.3.0 lub nowszej.

Inne podatności w PostgreSQL Anonymizer

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

PostgreSQL Anonymizer contains a vulnerability that data-modifying CTEs to bypass the read-only restriction of masked roles. The problem is resolved in PostgreSQL Anonymizer 3.3.0 and later versions

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS