CVE Catalog

CVE-2026-105612

LowCVSS 3.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.17%

6th percentile - higher than 6% of all known CVEs

Summary

PostgreSQL Anonymizer contains a vulnerability where data-modifying CTEs bypass the read-only restriction of masked roles. The problem is resolved in version 3.3.0 and later.

Risk Assessment

A masked role can modify data despite being intended as read-only, compromising data integrity.

Recommendation

Upgrade PostgreSQL Anonymizer to version 3.3.0 or later.

Other vulnerabilities in PostgreSQL Anonymizer

See all
Original NVD description (English source)

PostgreSQL Anonymizer contains a vulnerability that data-modifying CTEs to bypass the read-only restriction of masked roles. The problem is resolved in PostgreSQL Anonymizer 3.3.0 and later versions

Vulnerability data from NVD (NIST) · CISA KEV · EPSS