CVE Catalog

CVE-2026-105619

MediumCVSS 4.8
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.15%

4th percentile - higher than 4% of all known CVEs

Summary

PostgreSQL Anonymizer before 3.3.0 does not mask data accessed through a security_invoker view. The problem is resolved in version 3.3.0.

Risk Assessment

Users may access unmasked data through security_invoker views, bypassing the anonymization policy.

Recommendation

Upgrade PostgreSQL Anonymizer to version 3.3.0 or later and review views using the security_invoker option.

Other vulnerabilities in PostgreSQL Anonymizer

See all
Original NVD description (English source)

PostgreSQL Anonymizer doesn't mask data accessed thru a security_invoker view. The problem is resolved in PostgreSQL Anonymizer 3.3.0 and later versions.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS