CVE Catalog

CVE-2026-105613

MediumCVSS 4.7
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.18%

8th percentile - higher than 8% of all known CVEs

Summary

PostgreSQL Anonymizer's range-based dummy functions do not constrain the range size. This can be exploited to exhaust backend memory and OOM-kill it (when overcommit is on), resulting in cluster-wide crash recovery.

Risk Assessment

An attacker can cause memory exhaustion and a cluster-wide crash, leading to service unavailability and recovery overhead.

Recommendation

Upgrade PostgreSQL Anonymizer to version 3.3.0 or later.

Other vulnerabilities in PostgreSQL Anonymizer

See all
Original NVD description (English source)

PostgreSQL Anonymizer's range-based dummy functions dont constraint the range size. This vulnerability can be exploited to exhaust the memory of a backend and OOM-kill it (when ovecommit is on), which results in a cluster-wide crash recovery. The problem is resolved in PostgreSQL Anonymizer 3.3.0 and later versions.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS