Katalog CVE

CVE-2026-97869

ŚrednieCVSS 4.1
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Streszczenie

Wada w funkcji AgenticScopeSerializer.fromJson w komponencie LangChain4j-agentic powoduje problem z deserializacją. Atak zdalny jest możliwy, ale jego złożoność jest wysoka, a wykorzystanie trudne. Problem został naprawiony w wersjach 1.5.3-beta11, 1.11.10-beta19 i 1.18.1-beta28. Eksploit został opublikowany i może być użyty.

Ocena ryzyka

Ryzyko zdalnego wykonania kodu lub innych nieautoryzowanych działań, jeśli aplikacja korzysta z AgenticScope (ta funkcja jest opcjonalna). Wysoka złożoność ataku zmniejsza ryzyko, ale opublikowany eksploit zwiększa pilność aktualizacji.

Rekomendacja

Zaktualizuj komponent LangChain4j-agentic do wersji 1.5.3-beta11, 1.11.10-beta19 lub 1.18.1-beta28 (lub nowszych) i sprawdź, czy AgenticScope jest włączony w Twojej aplikacji - jeśli nie, rozważ jego wyłączenie.

Powiązane podatności

Oryginalny opis (angielski, źródło NVD)

A flaw has been found in langchain4j up to 1.5.3-beta10/1.11.10-beta18/1.18.1-beta27. This vulnerability affects the function AgenticScopeSerializer.fromJson of the file AgenticScopeJsonSerializationIT.java of the component LangChain4j-agentic. This manipulation causes deserialization. Remote exploitation of the attack is possible. The attack's complexity is rated as high. It is stated that the exploitability is difficult. The exploit has been published and may be used. Upgrading to version 1.5.3-beta11, 1.11.10-beta19 and 1.18.1-beta28 is able to resolve this issue. Upgrading the affected component is advised. The project maintainer kindly explains: "The issue was reported to us privately on 23 July 2026 and fixed in releases published on 29 July 2026. It is tracked as GHSA-gmwr-7wmf-mrjm. Exploitation requires an application to have enabled AgenticScope persistence, which is opt-in, and an attacker who can already write to that store. All maintained release lines have been patched."

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS