CVE Catalog

CVE-2026-97869

MediumCVSS 4.1
Published: Updated: Translated: NVD NIST

Summary

A flaw in the AgenticScopeSerializer.fromJson function in the LangChain4j-agentic component causes a deserialization issue. Remote exploitation is possible but complex and difficult. The issue is fixed in versions 1.5.3-beta11, 1.11.10-beta19, and 1.18.1-beta28. The exploit has been published and may be used.

Risk Assessment

Risk of remote code execution or other unauthorized actions if the application uses AgenticScope (this feature is opt-in). High attack complexity reduces risk, but a published exploit increases the urgency of patching.

Recommendation

Update the LangChain4j-agentic component to version 1.5.3-beta11, 1.11.10-beta19, or 1.18.1-beta28 (or later) and check if AgenticScope is enabled in your application - if not, consider disabling it.

Related vulnerabilities

Original NVD description (English source)

A flaw has been found in langchain4j up to 1.5.3-beta10/1.11.10-beta18/1.18.1-beta27. This vulnerability affects the function AgenticScopeSerializer.fromJson of the file AgenticScopeJsonSerializationIT.java of the component LangChain4j-agentic. This manipulation causes deserialization. Remote exploitation of the attack is possible. The attack's complexity is rated as high. It is stated that the exploitability is difficult. The exploit has been published and may be used. Upgrading to version 1.5.3-beta11, 1.11.10-beta19 and 1.18.1-beta28 is able to resolve this issue. Upgrading the affected component is advised. The project maintainer kindly explains: "The issue was reported to us privately on 23 July 2026 and fixed in releases published on 29 July 2026. It is tracked as GHSA-gmwr-7wmf-mrjm. Exploitation requires an application to have enabled AgenticScope persistence, which is opt-in, and an attacker who can already write to that store. All maintained release lines have been patched."

Vulnerability data from NVD (NIST) · CISA KEV · EPSS