CVE-2026-92087
WysokieCVSS 8.1Streszczenie
@fastify/auth w wersjach od 5.0.0 do 5.1.0 zawiera podatność związaną z kolejnością oceny strategii w trybie "or" z opcją "all", gdy jedna z nich jest zagnieżdżoną tablicą AND. Niektóre żądania mogą być autoryzowane, mimo że powinny zostać odrzucone (np. atakujący z ważnym kluczem API, ale niebędący administratorem).
Ocena ryzyka
Ryzyko nieautoryzowanego dostępu do chronionych zasobów, co może prowadzić do naruszenia bezpieczeństwa i integralności aplikacji.
Rekomendacja
Zaktualizuj @fastify/auth do wersji 5.1.1 lub nowszej. Jeśli nie można, unikaj opcji "all", porządkuj grupy AND tak, aby najsurowsza kontrola była na końcu, lub stosuj jawny komponent "and".
Powiązane podatności
- CVE-2026-116508Krytyczne
TOTOLINK A950RG 4.1.2cu.5268_B20221104 zawiera podatność na przepełnienie bufora na stosie w funkcji sub_402340 pliku infostat.cgi (komponent Device-Information CGI). Manipulacja argumentem CONTENT_LENGTH prowadzi do przepełnienia, a exploit jest publicznie dostępny.
- CVE-2026-116506Krytyczne
W urządzeniu TOTOLINK A950RG (wersja 4.1.2cu.5268_B20221104) funkcja apmib_set w pliku firewall.so jest podatna na wstrzyknięcie poleceń. Podatność może być wykorzystana zdalnie, a publiczny exploit jest dostępny.
- CVE-2026-116505Krytyczne
W urządzeniu TOTOLINK A950RG (wersja 4.1.2cu.5268_B20221104) funkcja getDeviceInfo w pliku /var/lib/misc/udhcpd.leases jest podatna na wstrzyknięcie poleceń poprzez manipulację argumentem adresu MAC. Atak może być przeprowadzony zdalnie, a exploit jest publicznie dostępny.
- CVE-2026-116504Krytyczne
W urządzeniu TOTOLINK A950RG (wersja 4.1.2cu.5268_B20221104) funkcja setCloudUpgradeFW w pliku lib/cste_modules/upgrade.so jest podatna na wstrzyknięcie poleceń poprzez manipulację argumentem FileName. Atak może być zainicjowany zdalnie, a exploit został publicznie ujawniony.
- CVE-2026-110720Krytyczne
consul-k8s w wersjach 0.42.0 i późniejszych zawiera obejście autoryzacji między przestrzeniami nazw w regułach wiązania ACL komponentów. Może to pozwolić atakującemu na uzyskanie podwyższonych uprawnień w Consulu.
- CVE-2026-10757Krytyczne
W Esri ArcGIS Server w wersjach 12.1 i starszych na Windows i Linux występuje podatność na wstrzyknięcie SQL, która może pozwolić zdalnemu atakującemu z uprawnieniami dostępu do usługi na wywoływanie funkcji specyficznych dla bazy danych, które nie powinny być dozwolone.
- CVE-2026-102649Krytyczne
Podatność w operatorze Kubernetes Burrito (Terraform Automation Collaboration Software) przed wersją 0.13.0 polega na tym, że endpoint POST /api/webhook akceptuje niepodpisane zdarzenia GitHub i GitLab, gdy poświadczenia TerraformRepository nie mają ustawionego webhookSecret lub jest on pusty. Umożliwia to osobie znającej URL śledzonego repozytorium sfałszowanie zdarzeń i utworzenie lub usunięcie zasobów TerraformPullRequest z wybranymi przez atakującego polami Branch, Base i ID. W przypadku zdarzeń pull_request z GitHuba kontroler pobiera zmienione pliki na podstawie prawdziwego numeru PR, ale nie weryfikuje gałęzi z payloadu, co może prowadzić do nieautoryzowanego terraform plan z użyciem przechowywanych poświadczeń git i chmurowych.
- CVE-2026-115905Krytyczne
W bibliotece zip dla Rusta do wersji 9.0.4 ZipArchive traktuje nazwy plików z nagłówka central directory jako wiążące, podczas gdy ZipStreamReader rozpakowuje przy użyciu nazw z lokalnego nagłówka pliku, bez uzgadniania zduplikowanych metadanych. Spreparowane archiwum może wyglądać nieszkodliwie dla komponentu sprawdzającego central directory, ale spowodować zapis innej ścieżki i zawartości przez ekstraktor strumieniowy.
- CVE-2026-112346Krytyczne
OpenHands Software Agent SDK przed wersją 1.52.0 zawiera podatność na nieuwierzytelnione zdalne wykonanie kodu. Launchery DockerWorkspace i Apptainer wiążą serwer agenta sandbox z wszystkimi interfejsami sieciowymi (0.0.0.0) z pustą listą session_api_keys, co domyślnie wyłącza uwierzytelnianie.
- CVE-2026-93328Krytyczne
W Google Cloud MCP Toolbox for Databases (googleapis/mcp-toolbox) w wersjach 1.2.0–1.4.0 występuje podatność typu path traversal oraz brak autoryzacji w źródle cloud-storage. Nieuwierzytelniony zdalny atakujący może eksfiltrować pliki hosta do zewnętrznych bucketów Google Cloud Storage oraz nadpisać dowolne pliki lokalne poprzez spreparowane parametry wywołania narzędzia.
Oryginalny opis (angielski, źródło NVD)
@fastify/auth is a Fastify plugin that composes multiple authentication and authorization strategies into a single route guard. In versions 5.0.0 through 5.1.0, when strategies are composed with the relation "or" option together with the run "all" option and one entry is a nested array acting as an AND group, the group is evaluated in an order-dependent way: an earlier failing check is silently dropped and the group's result becomes the outcome of its last check. As a result, a request that satisfies only the last member of an AND group, for example an attacker who holds a valid API key but is not an administrator, is authorized instead of rejected, and a related order-dependent bypass affects the mirror configuration where the top-level relation is "and" and a nested group uses "or". The issue is fixed in @fastify/auth 5.1.1, and users should upgrade to 5.1.1 or later. As a workaround, omit the run "all" option where it is not required, order each AND group so its stricter check is evaluated last, or replace nested AND groups with an explicit top-level "and" composition.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

