CVE Catalog

CVE-2026-92087

HighCVSS 8.1
Published: Updated: Translated: NVD NIST

Summary

@fastify/auth versions 5.0.0 through 5.1.0 have a vulnerability related to strategy evaluation order when using "or" relation with "all" option and a nested AND group. Some requests may be authorized when they should be rejected (e.g., an attacker with a valid API key but not an administrator).

Risk Assessment

Risk of unauthorized access to protected resources, potentially leading to security and integrity breaches.

Recommendation

Upgrade @fastify/auth to 5.1.1 or later. If not possible, omit the "all" option, order each AND group so the stricter check is last, or use explicit top-level "and" composition.

Related vulnerabilities

Original NVD description (English source)

@fastify/auth is a Fastify plugin that composes multiple authentication and authorization strategies into a single route guard. In versions 5.0.0 through 5.1.0, when strategies are composed with the relation "or" option together with the run "all" option and one entry is a nested array acting as an AND group, the group is evaluated in an order-dependent way: an earlier failing check is silently dropped and the group's result becomes the outcome of its last check. As a result, a request that satisfies only the last member of an AND group, for example an attacker who holds a valid API key but is not an administrator, is authorized instead of rejected, and a related order-dependent bypass affects the mirror configuration where the top-level relation is "and" and a nested group uses "or". The issue is fixed in @fastify/auth 5.1.1, and users should upgrade to 5.1.1 or later. As a workaround, omit the run "all" option where it is not required, order each AND group so its stricter check is evaluated last, or replace nested AND groups with an explicit top-level "and" composition.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS