CVE Catalog

CVE-2026-110720

CriticalCVSS 9.9
Published: Translated: NVD NIST

Summary

consul-k8s versions 0.42.0 and later are vulnerable to a cross-namespace authorization bypass in component ACL binding rules. This may allow an attacker to obtain elevated Consul privileges.

Risk Assessment

An attacker may gain elevated Consul privileges, potentially leading to unauthorized access to service configuration and data in the cluster. The vulnerability affects environments running consul-k8s 0.42.0 and later.

Recommendation

Upgrade consul-k8s to version 2.1.0 or 1.8.18, which contain the fix. Review component ACL binding rules for unexpected privileges.

Related vulnerabilities

Original NVD description (English source)

Consul-k8s versions 0.42.0 and later are vulnerable to a cross-namespace authorization bypass in component ACL binding rules that may allow an attacker to obtain elevated Consul privileges. This vulnerability (CVE-2026-110720) is fixed in consul-k8s 2.1.0 and 1.8.18.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS