Katalog CVE

CVE-2026-54559

ŚrednieCVSS 6.9
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.55%

Percentyl 44 - wyżej niż 44% wszystkich znanych CVE

Streszczenie

W PocketSphinx przed wersją 5.1.1 loadery modeli językowych trie w src/lm/ngram_model_trie.c nie walidują wystarczająco warunków brzegowych w nagłówkach formatów ARPA, DMP i binarnych, a loadery modeli akustycznych w src/mdef.c i src/util/bio.c używają sscanf z nieograniczonymi polami tekstowymi. Wczytanie nieprawidłowego lub złośliwego modelu może spowodować przepełnienie bufora stosu lub sterty i uszkodzenie pamięci.

Ocena ryzyka

Atakujący z możliwością zapisu do katalogu wskazanego przez POCKETSPHINX_PATH może zastąpić lub dodać plik modelu, powodując przepełnienie bufora i uszkodzenie pamięci, co może prowadzić do wykonania kodu lub awarii.

Rekomendacja

Zaktualizuj PocketSphinx do wersji 5.1.1; użytkownicy wersji 5prealpha nie mają backportowanej poprawki i muszą przejść na poprawione wydanie.

Powiązane podatności

Oryginalny opis (angielski, źródło NVD)

PocketSphinx is a small speech recognizer. Prior to 5.1.1, the trie language-model loaders in src/lm/ngram_model_trie.c do not adequately validate boundary conditions in ARPA, DMP, and binary format headers, and the acoustic-model loaders in src/mdef.c and src/util/bio.c use sscanf with unbounded string fields. Loading an invalid, corrupted, or malicious language or acoustic model can therefore cause stack or heap buffer overflows and memory corruption. An attacker who can write to a directory selected by POCKETSPHINX_PATH can replace or add a model file that PocketSphinx later loads; users of PocketSphinx 5prealpha have no backported patch and must migrate to the fixed release. This issue is fixed in version 5.1.1.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS