CVE Catalog

CVE-2026-54559

MediumCVSS 6.9
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.55%

44th percentile - higher than 44% of all known CVEs

Summary

In PocketSphinx prior to 5.1.1, the trie language-model loaders in src/lm/ngram_model_trie.c do not adequately validate boundary conditions in ARPA, DMP, and binary format headers, and the acoustic-model loaders in src/mdef.c and src/util/bio.c use sscanf with unbounded string fields. Loading an invalid or malicious model can cause stack or heap buffer overflows and memory corruption.

Risk Assessment

An attacker able to write to a directory selected by POCKETSPHINX_PATH can replace or add a model file, causing buffer overflow and memory corruption, potentially leading to code execution or crash.

Recommendation

Upgrade PocketSphinx to version 5.1.1; users of 5prealpha have no backported patch and must migrate to the fixed release.

Related vulnerabilities

Original NVD description (English source)

PocketSphinx is a small speech recognizer. Prior to 5.1.1, the trie language-model loaders in src/lm/ngram_model_trie.c do not adequately validate boundary conditions in ARPA, DMP, and binary format headers, and the acoustic-model loaders in src/mdef.c and src/util/bio.c use sscanf with unbounded string fields. Loading an invalid, corrupted, or malicious language or acoustic model can therefore cause stack or heap buffer overflows and memory corruption. An attacker who can write to a directory selected by POCKETSPHINX_PATH can replace or add a model file that PocketSphinx later loads; users of PocketSphinx 5prealpha have no backported patch and must migrate to the fixed release. This issue is fixed in version 5.1.1.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS