Katalog CVE

CVE-2026-31953

ŚrednieCVSS 6.4
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.14%

Percentyl 3 - wyżej niż 3% wszystkich znanych CVE

Streszczenie

Xibo (platforma digital signage z systemem CMS i odtwarzaczem dla Windows) w wersjach przed 4.4.1 zawiera podatność przechowywanego XSS. Uwierzytelniony użytkownik z uprawnieniami do tworzenia powiadomień może wstrzyknąć dowolny JavaScript do treści powiadomienia. Gdy powiadomienie jest ustawione jako „interrupt”, ładunek wykonuje się automatycznie w przeglądarce każdego docelowego użytkownika przy logowaniu, bez interakcji użytkownika. Wymaga to uprawnień do Notification Centre i przycisku „Add Notification”, które nie są standardowo przyznawane nieadministratorom. Naprawiono w wersji 4.4.1.

Ocena ryzyka

Atakujący z odpowiednimi uprawnieniami może wykonać dowolny JavaScript w przeglądarkach innych użytkowników, potencjalnie przejmując ich sesje lub wykonując działania w ich imieniu.

Rekomendacja

Zaktualizuj Xibo do wersji 4.4.1; jeśli aktualizacja nie jest możliwa, odbierz uprawnienia do tworzenia powiadomień niezaufanym użytkownikom.

Inne podatności w Xibo

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

Xibo is an open source digital signage platform with a web content management system and Windows display player software. A stored Cross-Site Scripting (XSS) vulnerability in versions prior to 4.4.1 allows an authenticated user with notification creation permissions to inject arbitrary JavaScript into the notification body. When the notification is set as an "interrupt," the payload executes automatically in the browser of any targeted user upon login, requiring zero user interaction. Exploitation of the vulnerability is possible on behalf of an authorized user who has both of the following privileges, which are not granted to non-admins as standard: Access to the Notification Centre to view past notifications, and include "Add Notification" button to allow for the creation of new notifications. Users should upgrade to version 4.4.1 which fixes this issue. Upgrading to a fixed version is necessary to remediate. Users unable to upgrade should revoke such privileges from users they do not trust.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS