CVE Catalog

CVE-2026-31953

MediumCVSS 6.4
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.14%

3th percentile - higher than 3% of all known CVEs

Summary

Xibo (an open source digital signage platform with a web CMS and Windows player) prior to 4.4.1 contains a stored XSS vulnerability. An authenticated user with notification creation permissions can inject arbitrary JavaScript into the notification body. When the notification is set as an "interrupt," the payload executes automatically in the browser of any targeted user upon login, requiring zero user interaction. This requires Notification Centre access and the "Add Notification" button, which are not granted to non-admins by default. Fixed in 4.4.1.

Risk Assessment

An attacker with the required privileges can execute arbitrary JavaScript in other users' browsers, potentially hijacking their sessions or performing actions on their behalf.

Recommendation

Upgrade Xibo to version 4.4.1; if upgrade is not possible, revoke notification creation privileges from untrusted users.

Other vulnerabilities in Xibo

See all
Original NVD description (English source)

Xibo is an open source digital signage platform with a web content management system and Windows display player software. A stored Cross-Site Scripting (XSS) vulnerability in versions prior to 4.4.1 allows an authenticated user with notification creation permissions to inject arbitrary JavaScript into the notification body. When the notification is set as an "interrupt," the payload executes automatically in the browser of any targeted user upon login, requiring zero user interaction. Exploitation of the vulnerability is possible on behalf of an authorized user who has both of the following privileges, which are not granted to non-admins as standard: Access to the Notification Centre to view past notifications, and include "Add Notification" button to allow for the creation of new notifications. Users should upgrade to version 4.4.1 which fixes this issue. Upgrading to a fixed version is necessary to remediate. Users unable to upgrade should revoke such privileges from users they do not trust.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS