Katalog CVE

CVE-2026-120213

KrytyczneCVSS 9.1
Opublikowano: Przetłumaczono: NVD NIST

Streszczenie

Wtyczka @fastify/http-proxy w wersjach 9.0.0–11.6.5 nie ponownie koduje zdekodowanych parametrów trasy wstawianych do rewritePrefix. Wartość parametru kodująca separator ścieżki wraz z ogranicznikiem fragmentu lub zapytania dekoduje się do rzeczywistych separatorów, co pozwala wstrzyknąć dodatkowe segmenty ścieżki upstream i pominąć wymagany sufiks. Nieuwierzytelniony zdalny atakujący może uzyskać dostęp do lokalizacji poza zamierzonym prefiksem, co prowadzi do obejścia ograniczeń ścieżki, a w zależności od upstreamu do SSRF lub obejścia autoryzacji.

Ocena ryzyka

Atakujący może ominąć ograniczenia ścieżki proxy i dotrzeć do nieprzewidzianych zasobów upstream, co może skutkować ujawnieniem danych lub obejściem kontroli dostępu w usłudze proxy. Wymaga to jednego nieuwierzytelnionego żądania, więc ryzyko jest wysokie dla aplikacji korzystających z parametryzowanych prefiksów.

Rekomendacja

Zaktualizuj @fastify/http-proxy do wersji 11.6.6 lub nowszej. Nie ma innego obejścia niż aktualizacja.

Inne podatności w @fastify/http-proxy

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

@fastify/http-proxy is a Fastify plugin that proxies HTTP requests to an upstream server under a configured prefix. In versions 9.0.0 through 11.6.5, when an application uses parameterized prefix and rewritePrefix options to pin clients to a fixed upstream path, the plugin substitutes URL-decoded route parameters into rewritePrefix without re-encoding them. A parameter value that encodes a path separator together with a fragment or query delimiter therefore decodes into real separators and delimiters that inject extra upstream path segments and strip the mandatory suffix the rewritePrefix was meant to enforce, without using any dot-dot traversal. An unauthenticated remote attacker can use this to reach upstream locations outside the intended prefix, leading to path-restriction bypass and, depending on the upstream, server-side request forgery or authorization bypass in the proxied service. The issue is fixed in @fastify/http-proxy 11.6.6, and users should upgrade to 11.6.6 or later. There is no workaround other than upgrading.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS