CVE Catalog

CVE-2026-120213

CriticalCVSS 9.1
Published: Translated: NVD NIST

Summary

@fastify/http-proxy versions 9.0.0 through 11.6.5 substitute URL-decoded route parameters into rewritePrefix without re-encoding them. A parameter value encoding a path separator with a fragment or query delimiter decodes into real separators, injecting extra upstream path segments and stripping the mandatory suffix. An unauthenticated remote attacker can reach upstream locations outside the intended prefix, leading to path-restriction bypass and, depending on the upstream, SSRF or authorization bypass.

Risk Assessment

An attacker can bypass proxy path restrictions and reach unintended upstream resources, potentially exposing data or bypassing access controls in the proxied service. Exploitation requires a single unauthenticated request, making the risk high for applications using parameterized prefixes.

Recommendation

Upgrade @fastify/http-proxy to version 11.6.6 or later. There is no workaround other than upgrading.

Other vulnerabilities in @fastify/http-proxy

See all
Original NVD description (English source)

@fastify/http-proxy is a Fastify plugin that proxies HTTP requests to an upstream server under a configured prefix. In versions 9.0.0 through 11.6.5, when an application uses parameterized prefix and rewritePrefix options to pin clients to a fixed upstream path, the plugin substitutes URL-decoded route parameters into rewritePrefix without re-encoding them. A parameter value that encodes a path separator together with a fragment or query delimiter therefore decodes into real separators and delimiters that inject extra upstream path segments and strip the mandatory suffix the rewritePrefix was meant to enforce, without using any dot-dot traversal. An unauthenticated remote attacker can use this to reach upstream locations outside the intended prefix, leading to path-restriction bypass and, depending on the upstream, server-side request forgery or authorization bypass in the proxied service. The issue is fixed in @fastify/http-proxy 11.6.6, and users should upgrade to 11.6.6 or later. There is no workaround other than upgrading.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS