Katalog CVE

CVE-2026-110288

ŚrednieCVSS 5.3
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.19%

Percentyl 8 - wyżej niż 8% wszystkich znanych CVE

Streszczenie

W GitHub Enterprise Server zidentyfikowano podatność CSRF, która pozwalała nieuwierzytelnionemu atakującemu usunąć zapisaną konfigurację ChatOps dla Slack i Microsoft Teams oraz dane uwierzytelniające dostawców poprzez nakłonienie zalogowanego operatora Management Console do wysłania żądania GET do punktu końcowego usuwania integracji bez tokenu CSRF. Wykorzystanie wymagało skonfigurowanych integracji ChatOps oraz odwiedzenia przez operatora treści kontrolowanych przez atakującego. Podatność dotyczyła wszystkich wersji GitHub Enterprise Server przed 3.23 i została naprawiona w wersjach 3.19.14, 3.20.10, 3.21.8 i 3.22.3.

Ocena ryzyka

Usunięcie konfiguracji ChatOps i danych uwierzytelniających może zakłócić powiadomienia i polecenia ChatOps, a także utrudnić integrację z Slack i Microsoft Teams.

Rekomendacja

Zaktualizuj GitHub Enterprise Server do wersji 3.19.14, 3.20.10, 3.21.8 lub 3.22.3 (lub nowszej) i poinformuj operatorów o ryzyku odwiedzania niezaufanych treści podczas zalogowania.

Inne podatności w GitHub Enterprise Server

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

A cross-site request forgery vulnerability was identified in GitHub Enterprise Server that allowed an unauthenticated attacker to delete stored Slack and Microsoft Teams ChatOps configuration and provider credentials by inducing an authenticated Management Console operator's browser to send a cross-site GET request to the integration removal endpoint without a CSRF token. Exploitation required configured ChatOps integrations and an operator visiting attacker-controlled content while signed in to the Management Console; deletion could disrupt ChatOps notifications and commands when configuration was applied or services reloaded. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.23 and was fixed in versions 3.19.14, 3.20.10, 3.21.8, and 3.22.3. This vulnerability was reported via the GitHub Bug Bounty program.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS