CVE-2025-66675
WysokieCVSS 8.2Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 47 - wyżej niż 47% wszystkich znanych CVE
Streszczenie
Podatność typu Denial of Service w Apache Struts — wyciek plików podczas przetwarzania żądań multipart powoduje wyczerpanie miejsca na dysku. Dotyczy wersji od 2.0.0 do 6.7.4 oraz od 7.0.0 do 7.0.3.
Ocena ryzyka
Atakujący może doprowadzić do zapełnienia dysku serwera, co uniemożliwi działanie aplikacji i może wpłynąć na cały host.
Rekomendacja
Zaktualizuj Apache Struts do wersji 6.8.0 lub 7.1.1, która naprawia tę podatność.
Inne podatności w Apache Struts
Zobacz wszystkie- CVE-2016-3090Wysokie
Metoda TextParseUtil.translateVariables w Apache Struts 2.x przed wersją 2.3.20 umożliwia zdalnym atakującym wykonanie dowolnego kodu poprzez spreparowane wyrażenie OGNL z wykorzystaniem narzędzi ANTLR.
- CVE-2016-4461Wysokie
Apache Struts 2.x przed wersją 2.3.29 umożliwia zdalnym atakującym wykonanie dowolnego kodu poprzez sekwencję "%{}" w atrybucie tagu, co jest znane jako wymuszone podwójne ocenianie OGNL.
- CVE-2017-9804Wysokie
W Apache Struts w wersjach od 2.3.7 do 2.3.33 oraz od 2.5 do 2.5.12, istnieje możliwość przygotowania specjalnego URL, który może przeciążyć proces serwera podczas walidacji URL w formularzu. Problem ten wynika z niekompletnej poprawki dla S2-047 / CVE-2017-7672.
- CVE-2015-5209Wysokie
Apache Struts 2.x przed wersją 2.3.24.1 pozwala zdalnym atakującym na manipulację wewnętrznymi elementami Struts, co może prowadzić do zmiany sesji użytkowników lub wpływania na ustawienia kontenera.
- CVE-2017-9787Wysokie
Wykorzystanie funkcjonalności AOP w Spring do zabezpieczania akcji Struts może prowadzić do ataku DoS.
- CVE-2016-4433Wysokie
Apache Struts 2 w wersjach od 2.3.20 do 2.3.28.1 pozwala zdalnym atakującym na obejście zamierzonych ograniczeń dostępu oraz przeprowadzenie ataków redirekcyjnych za pomocą spreparowanego żądania.
- CVE-2016-4431Wysokie
Apache Struts 2 w wersjach od 2.3.20 do 2.3.28.1 pozwala zdalnym atakującym na obejście zamierzonych ograniczeń dostępu oraz przeprowadzanie ataków redirekcyjnych poprzez wykorzystanie domyślnej metody.
- CVE-2016-4430Wysokie
Apache Struts 2 w wersjach od 2.3.20 do 2.3.28.1 niewłaściwie obsługuje walidację tokenów, co umożliwia zdalnym atakującym przeprowadzanie ataków typu cross-site request forgery (CSRF) za pomocą nieokreślonych wektorów.
- CVE-2016-0785Wysokie
Apache Struts 2.x przed wersją 2.3.28 umożliwia zdalnym atakującym wykonanie dowolnego kodu poprzez sekwencję "%{}" w atrybucie tagu, co jest znane jako wymuszone podwójne ocenianie OGNL.
- CVE-2015-1831Wysokie
Domyślne wzorce wykluczeń (excludeParams) w Apache Struts 2.3.20 umożliwiają zdalnym atakującym kompromitację wewnętrznego stanu aplikacji za pomocą nieokreślonych wektorów.
Oryginalny opis (angielski, źródło NVD)
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.4, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue. It's related to https://cve.org/CVERecord?id=CVE-2025-64775 - this CVE addresses missing affected version 6.7.4
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

