CVE Catalog

CVE-2025-66675

HighCVSS 8.2
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.59%

47th percentile - higher than 47% of all known CVEs

Summary

Denial of Service vulnerability in Apache Struts — a file leak in multipart request processing causes disk exhaustion. It affects Apache Struts from 2.0.0 through 6.7.4 and from 7.0.0 through 7.0.3.

Risk Assessment

An attacker can fill up the server disk, disrupting application availability and potentially affecting the entire host.

Recommendation

Upgrade Apache Struts to version 6.8.0 or 7.1.1, which fixes the issue.

Other vulnerabilities in Apache Struts

See all
Original NVD description (English source)

Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.4, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue. It's related to  https://cve.org/CVERecord?id=CVE-2025-64775  - this CVE addresses missing affected version 6.7.4

Vulnerability data from NVD (NIST) · CISA KEV · EPSS