CVE-2025-61590
WysokieCVSS 7.5Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 43 - wyżej niż 43% wszystkich znanych CVE
Streszczenie
Cursor to edytor kodu zbudowany do programowania z użyciem AI. Wersje 1.6 i starsze są podatne na ataki zdalnego wykonania kodu (RCE) poprzez przestrzenie robocze Visual Studio Code. Jeśli atakujący przejmie kontekst czatu ofiary (np. przez przejęty serwer MCP), może użyć prompt injection, aby zmusić agenta Cursor do zapisu w pliku przestrzeni roboczej i modyfikacji ustawień, co omija poprawkę CVE-2025-54130 i prowadzi do RCE.
Ocena ryzyka
Atakujący może zdalnie wykonać dowolny kod w środowisku ofiary, co może prowadzić do pełnego przejęcia stacji roboczej i kradzieży danych programisty.
Rekomendacja
Zaktualizuj Cursor do wersji 1.7 lub nowszej.
Inne podatności w Cursor
Zobacz wszystkie- CVE-2026-73218Wysokie
Cursor IDE dla macOS przed wersją 3.0.0 pozwala agentowi działającemu w trybie Auto-Run Sandbox, gdy zainstalowane są Docker Desktop i Dev Containers CLI, na uruchomienie uprzywilejowanego kontenera i zamontowanie virtiofs0 Docker, co daje odczyt i zapis do katalogu domowego użytkownika oraz umożliwia wykonywanie poleceń na hoście z uprawnieniami użytkownika bez dodatkowego monitu o zgodę.
- CVE-2026-73217Wysokie
Cursor IDE dla macOS przed wersją 3.1.2 pozwala agentowi działającemu w trybie Auto-Run Sandbox na zastąpienie pliku wykonywalnego Pythona w środowisku wirtualnym złośliwym wrapperem, który rozszerzenie Microsoft Python wywołuje poza sandboxem, umożliwiając wykonywanie dowolnych poleceń na hoście z uprawnieniami użytkownika, w tym modyfikację plików poza obszarem roboczym i uruchamianie aplikacji.
- CVE-2026-63093Wysokie
Podatność polegająca na podstawieniu złośliwego pliku git.exe w katalogu głównym repozytorium. Gdy programista sklonuje i otworzy spreparowane repozytorium, Cursor automatycznie uruchomi złośliwy plik bez interakcji użytkownika, co prowadzi do wykonania dowolnego kodu.
- CVE-2026-61613Wysokie
Podatność w edytorze Cursor przed 31.03.2026 umożliwiała atakującym kontrolowaną treść webową na połączenie z nieuwierzytelnionym lokalnym endpointem agenta w chmurze, co pozwalało na wykonanie kodu w piaskownicy agenta oraz dostęp do plików, repozytoriów, zmiennych środowiskowych, poświadczeń i tokenów GitHub App. Problem został naprawiony 31.03.2026 przez wymuszenie uwierzytelniania dla odpowiedniego endpointu.
- CVE-2025-64110Wysokie
W edytorze kodu Cursor w wersjach 1.7.23 i starszych występuje błąd logiczny, który pozwala złośliwemu agentowi AI odczytać pliki chronione przez cursorignore. Atakujący, który uzyskał już prompt injection lub kontroluje model, może utworzyć nowy plik cursorignore, unieważniając konfigurację istniejących plików i uzyskując dostęp do chronionych danych.
- CVE-2025-64108Wysokie
Cursor w wersjach 1.7.44 i wcześniejszych ma podatność związaną z obejściami ścieżek NTFS, które pozwalają atakującemu wykorzystującemu prompt injection na obejście ochrony wrażliwych plików i nadpisanie plików wymagających zatwierdzenia przez człowieka. Modyfikacja niektórych chronionych plików może prowadzić do RCE.
- CVE-2025-64107Wysokie
W edytorze Cursor w wersjach 1.7.52 i starszych manipulacja wewnętrznymi ustawieniami może prowadzić do zdalnego wykonania kodu (RCE). Cursor wykrywa manipulację ścieżkami za pomocą ukośników (./.cursor/./././././mcp.json), ale nie wykrywa poprawnie tej samej manipulacji przy użyciu odwrotnych ukośników, co pozwala na nadpisanie wrażliwych plików edytora bez zatwierdzenia na systemach Windows.
- CVE-2025-64106Wysokie
W Cursor w wersjach 1.7.28 i starszych błąd walidacji danych wejściowych przy instalacji serwera MCP pozwala spreparowanym deep-linkom ominąć standardowe ostrzeżenia bezpieczeństwa i ukryć wykonywane polecenia przed użytkownikiem. Jeśli ofiara zaakceptuje serwer, wykonane zostaną polecenia wskazane przez atakującego.
- CVE-2025-59944Wysokie
Cursor IDE w wersjach 1.6.23 i starszych stosuje sprawdzanie wielkości liter przy ochronie plików wrażliwych (np. */.cursor/mcp.json), co pozwala atakującemu zmodyfikować ich zawartość przez prompt injection. Na systemach plików nierozróżniających wielkości liter może to prowadzić do pełnego zdalnego wykonania kodu.
- CVE-2025-61592Wysokie
Podatność w edytorze Cursor w wersjach 1.7 i niższych. Automatyczne ładowanie konfiguracji CLI z katalogu projektu (.cursor/cli.json) może nadpisać globalne ustawienia i umożliwić zdalne wykonanie kodu poprzez połączenie permisywnej konfiguracji i wstrzyknięcia promptu.
Oryginalny opis (angielski, źródło NVD)
Cursor is a code editor built for programming with AI. Versions 1.6 and below are vulnerable to Remote Code Execution (RCE) attacks through Visual Studio Code Workspaces. Workspaces allow users to open more than a single folder and save specific settings (pretty similar to .vscode/settings.json) for the folders / project. An untitled workspace is automatically created by VS Code (untitled.code-workspace), which contains all the folders and workspace settings from the user's current session, opening up an entire new attack vector if the user has a .code-workspace file in path (either untitled created automatically or a saved one). If an attacker is able to hijack the chat context of the victim (such as via a compromised MCP server), they can use prompt injection to make the Cursor Agent write into this file and modify the workspace. This leads to a bypass of CVE-2025-54130 which can lead to RCE by writing to the settings section. This issue is fixed in version 1.7.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

