Katalog CVE

CVE-2025-64110

WysokieCVSS 7.5
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.39%

Percentyl 32 - wyżej niż 32% wszystkich znanych CVE

Streszczenie

W edytorze kodu Cursor w wersjach 1.7.23 i starszych występuje błąd logiczny, który pozwala złośliwemu agentowi AI odczytać pliki chronione przez cursorignore. Atakujący, który uzyskał już prompt injection lub kontroluje model, może utworzyć nowy plik cursorignore, unieważniając konfigurację istniejących plików i uzyskując dostęp do chronionych danych.

Ocena ryzyka

Może dojść do wycieku wrażliwych plików (np. kluczy, konfiguracji) z projektów programistycznych, jeśli agent AI zostanie przejęty przez atakującego.

Rekomendacja

Zaktualizuj Cursor do wersji 2.0 lub nowszej, która naprawia tę podatność.

Inne podatności w Cursor

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

Cursor is a code editor built for programming with AI. In versions 1.7.23 and below, a logic bug allows a malicious agent to read sensitive files that should be protected via cursorignore. An attacker who has already achieved prompt injection, or a malicious model, could create a new cursorignore file which can invalidate the configuration of pre-existing ones. This could allow a malicious agent to read protected files. This issue is fixed in version 2.0.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS