Katalog CVE

CVE-2025-59933

WysokieCVSS 7.8
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.19%

Percentyl 8 - wyżej niż 8% wszystkich znanych CVE

Streszczenie

W libvips w wersjach 8.17.1 i starszych, gdy biblioteka jest skompilowana z obsługą PDF przez poppler, operacja pdfload ma przepełnienie odczytu bufora podczas parsowania nagłówka spreparowanego PDF ze stroną określającą szerokość, ale nie wysokość. Problem naprawiono w wersji 8.17.2.

Ocena ryzyka

Przetwarzanie złośliwego pliku PDF przez libvips może spowodować odczyt poza buforem, co może prowadzić do awarii lub ujawnienia danych.

Rekomendacja

Zaktualizuj libvips do wersji 8.17.2 lub nowszej; jako obejście zablokuj operację VipsForeignLoadPdf lub ustaw zmienną środowiskową VIPS_BLOCK_UNTRUSTED.

Inne podatności w libvips

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

libvips is a demand-driven, horizontally threaded image processing library. For versions 8.17.1 and below, when libvips is compiled with support for PDF input via poppler, the pdfload operation is affected by a buffer read overflow when parsing the header of a crafted PDF with a page that defines a width but not a height. Those using libvips compiled without support for PDF input are unaffected as well as thosewith support for PDF input via PDFium. This issue is fixed in version 8.17.2. A workaround for those affected is to block the VipsForeignLoadPdf operation via vips_operation_block_set, which is available in most language bindings, or to set VIPS_BLOCK_UNTRUSTED environment variable at runtime, which will block all untrusted loaders including PDF input via poppler.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS