CVE Catalog

CVE-2025-59933

HighCVSS 7.8
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.19%

8th percentile - higher than 8% of all known CVEs

Summary

In libvips versions 8.17.1 and below, when compiled with PDF support via poppler, the pdfload operation has a buffer read overflow when parsing the header of a crafted PDF with a page defining width but not height. Fixed in version 8.17.2.

Risk Assessment

Processing a malicious PDF with libvips could cause an out-of-bounds read, potentially leading to a crash or data disclosure.

Recommendation

Update libvips to version 8.17.2 or later; as a workaround, block the VipsForeignLoadPdf operation or set the VIPS_BLOCK_UNTRUSTED environment variable.

Other vulnerabilities in libvips

See all
Original NVD description (English source)

libvips is a demand-driven, horizontally threaded image processing library. For versions 8.17.1 and below, when libvips is compiled with support for PDF input via poppler, the pdfload operation is affected by a buffer read overflow when parsing the header of a crafted PDF with a page that defines a width but not a height. Those using libvips compiled without support for PDF input are unaffected as well as thosewith support for PDF input via PDFium. This issue is fixed in version 8.17.2. A workaround for those affected is to block the VipsForeignLoadPdf operation via vips_operation_block_set, which is available in most language bindings, or to set VIPS_BLOCK_UNTRUSTED environment variable at runtime, which will block all untrusted loaders including PDF input via poppler.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS