CVE-2025-58769
NiskieCVSS 3.3Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 27 - wyżej niż 27% wszystkich znanych CVE
Streszczenie
auth0-PHP to SDK dla API Auth0. W wersjach 3.3.0 do 8.16.0 endpoint Bulk User Import nie waliduje opakowania ani wartości ścieżki pliku, co może pozwolić na akceptację dowolnych ścieżek lub URLi. Podatność dotyczy aplikacji bezpośrednio używających SDK lub pośrednio przez Auth0/symfony, Auth0/laravel-auth0 lub Auth0/wordpress; naprawiono w wersji 8.17.0.
Ocena ryzyka
Atakujący może wykorzystać nieprawidłową walidację do dostarczenia dowolnych ścieżek plików lub URLi, co może prowadzić do nieautoryzowanego dostępu do danych lub dalszej kompromitacji. Dotyczy to aplikacji korzystających z wymienionych SDK.
Rekomendacja
Zaktualizuj auth0-PHP do wersji 8.17.0 lub nowszej oraz powiązane SDK (Auth0/symfony, Auth0/laravel-auth0, Auth0/wordpress) do wersji zawierających poprawkę. Sprawdź, czy endpoint Bulk User Import jest prawidłowo zabezpieczony.
Inne podatności w auth0-PHP
Oryginalny opis (angielski, źródło NVD)
auth0-PHP is an SDK for Auth0 Authentication and Management APIs. In versions 3.3.0 through 8.16.0, the Bulk User Import endpoint in applications built with the SDK does not validate the file-path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs. The vulnerability affects any application that either directly uses the Auth0-PHP SDK (versions 3.3.0–8.16.0) or indirectly relies on those versions through the Auth0/symfony, Auth0/laravel-auth0, or Auth0/wordpress SDKs. This issue is fixed in version 8.17.0.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

