CVE Catalog

CVE-2025-58769

LowCVSS 3.3
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.35%

27th percentile - higher than 27% of all known CVEs

Summary

auth0-PHP is an SDK for Auth0 APIs. In versions 3.3.0 through 8.16.0, the Bulk User Import endpoint does not validate the file-path wrapper or value, potentially accepting arbitrary file paths or URLs. The vulnerability affects applications directly using the SDK or indirectly via Auth0/symfony, Auth0/laravel-auth0, or Auth0/wordpress; it is fixed in version 8.17.0.

Risk Assessment

An attacker could exploit the lack of validation to supply arbitrary file paths or URLs, potentially leading to unauthorized data access or further compromise. This affects applications using the listed SDKs.

Recommendation

Update auth0-PHP to version 8.17.0 or later and update related SDKs (Auth0/symfony, Auth0/laravel-auth0, Auth0/wordpress) to versions containing the fix. Verify that the Bulk User Import endpoint is properly secured.

Other vulnerabilities in auth0-PHP

Original NVD description (English source)

auth0-PHP is an SDK for Auth0 Authentication and Management APIs. In versions 3.3.0 through 8.16.0, the Bulk User Import endpoint in applications built with the SDK does not validate the file-path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs. The vulnerability affects any application that either directly uses the Auth0-PHP SDK (versions 3.3.0–8.16.0) or indirectly relies on those versions through the Auth0/symfony, Auth0/laravel-auth0, or Auth0/wordpress SDKs. This issue is fixed in version 8.17.0.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS