CVE Catalog

CVE-2026-83525

Low risk· EPSS 8%
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.19%

8th percentile - higher than 8% of all known CVEs

Summary

Incorrect operator (CWE-480) in the FetchSnapshot RPC handler in Apache Kafka from 2.8.0 before 4.2.2, and from 4.3.0 before 4.3.2, allows an authenticated attacker with CLUSTER_ACTION privilege to cause a denial of service. Exploitation occurs via a crafted FetchSnapshotRequest with an empty topics array or a topic with no partitions, terminating the controller process.

Risk Assessment

An authenticated attacker with appropriate privileges could terminate the Kafka controller process, causing cluster unavailability. This may disrupt systems relying on stream processing.

Recommendation

Upgrade Apache Kafka to version 4.2.2, 4.3.2, or 4.4.0. Users on unsupported branches (4.1.x and earlier) should upgrade to 4.2.2 or later.

Other vulnerabilities in Apache Kafka

See all
Original NVD description (English source)

Incorrect operator (CWE-480) in the FetchSnapshot RPC handler in Apache Kafka from 2.8.0 before 4.2.2, and from 4.3.0 before 4.3.2 on all platforms allows an authenticated attacker with CLUSTER_ACTION privilege to cause a denial of service (controller process termination) via a crafted FetchSnapshotRequest with an empty topics array or a topic with no partitions. Users are recommended to upgrade to version 4.2.2, 4.3.2, or 4.4.0, which fix this issue. Users on unsupported branches (4.1.x and earlier) should upgrade to 4.2.2 or later.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS