CVE Catalog

CVE-2025-64894

MediumCVSS 5.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.17%

6th percentile - higher than 6% of all known CVEs

Summary

DNG SDK versions 1.7.0 and earlier are affected by an Integer Overflow or Wraparound vulnerability that could lead to application denial-of-service. An attacker could exploit this issue to cause the application to crash or become unresponsive. Exploitation requires user interaction in that a victim must open a malicious file.

Risk Assessment

Successful exploitation can cause the DNG-processing application to crash or become unresponsive, disrupting user workflows. The risk is limited because it requires a victim to open a malicious file.

Recommendation

Update DNG SDK to a version later than 1.7.0 once a fix is available. Until then, avoid opening DNG files from untrusted sources.

Other vulnerabilities in DNG SDK

See all
Original NVD description (English source)

DNG SDK versions 1.7.0 and earlier are affected by an Integer Overflow or Wraparound vulnerability that could lead to application denial-of-service. An attacker could exploit this issue to cause the application to crash or become unresponsive. Exploitation of this issue requires user interaction in that a victim must open a malicious file.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS