CVE Catalog

CVE-2025-64893

HighCVSS 7.1
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.18%

7th percentile - higher than 7% of all known CVEs

Summary

DNG SDK versions 1.7.0 and earlier are affected by an out-of-bounds read vulnerability that could lead to memory exposure or application denial of service. An attacker could leverage this vulnerability to disclose sensitive information stored in memory. Exploitation requires user interaction, as the victim must open a malicious file.

Risk Assessment

The vulnerability may lead to leakage of sensitive data from process memory or to application crashes, posing risks to confidentiality and availability. This is particularly relevant for applications processing untrusted DNG files.

Recommendation

Update DNG SDK to a version later than 1.7.0 if available. Until then, avoid opening DNG files from untrusted sources.

Other vulnerabilities in DNG SDK

See all
Original NVD description (English source)

DNG SDK versions 1.7.0 and earlier are affected by an Out-of-bounds Read vulnerability that could lead to memory exposure or application denial of service. An attacker could leverage this vulnerability to disclose sensitive information stored in memory. Exploitation of this issue requires user interaction in that a victim must open a malicious file.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS