CVE Catalog

CVE-2025-64784

HighCVSS 7.1
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.20%

9th percentile - higher than 9% of all known CVEs

Summary

DNG SDK versions 1.7.0 and earlier are affected by a Heap-based Buffer Overflow vulnerability that could lead to memory exposure or application denial of service. An attacker could leverage this vulnerability to disclose sensitive memory information. Exploitation of this issue requires user interaction in that a victim must open a malicious file.

Risk Assessment

Opening a malicious file may lead to memory data leakage or application crash, posing a risk to data confidentiality and service availability.

Recommendation

Update DNG SDK to a version later than 1.7.0 and avoid opening files from untrusted sources.

Other vulnerabilities in DNG SDK

See all
Original NVD description (English source)

DNG SDK versions 1.7.0 and earlier are affected by a Heap-based Buffer Overflow vulnerability that could lead to memory exposure or application denial of service. An attacker could leverage this vulnerability to disclose sensitive memory information. Exploitation of this issue requires user interaction in that a victim must open a malicious file.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS