CVE Catalog

CVE-2025-62164

HighCVSS 8.8
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Elevated risk
0.93%

60th percentile - higher than 60% of all known CVEs

Summary

A vulnerability in vLLM (versions 0.10.2 to before 0.11.1) in the Completions API endpoint. When processing user-supplied prompt embeddings, the server loads serialized tensors via torch.load() without sufficient validation. Due to a change in PyTorch 2.8.0, sparse tensor integrity checks are disabled by default, allowing maliciously crafted tensors to bypass bounds checks and trigger an out-of-bounds memory write during to_dense(), leading to a crash (DoS) and potentially remote code execution (RCE).

Risk Assessment

An attacker could remotely crash the vLLM service or execute arbitrary code on the server hosting vLLM, potentially leading to full system compromise and access to data and models.

Recommendation

Update vLLM to version 0.11.1 or later. Until then, restrict access to the Completions API endpoint and consider validating or rejecting user-supplied prompt embeddings.

Other vulnerabilities in vLLM

See all
Original NVD description (English source)

vLLM is an inference and serving engine for large language models (LLMs). From versions 0.10.2 to before 0.11.1, a memory corruption vulnerability could lead to a crash (denial-of-service) and potentially remote code execution (RCE), exists in the Completions API endpoint. When processing user-supplied prompt embeddings, the endpoint loads serialized tensors using torch.load() without sufficient validation. Due to a change introduced in PyTorch 2.8.0, sparse tensor integrity checks are disabled by default. As a result, maliciously crafted tensors can bypass internal bounds checks and trigger an out-of-bounds memory write during the call to to_dense(). This memory corruption can crash vLLM and potentially lead to code execution on the server hosting vLLM. This issue has been patched in version 0.11.1.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS