CVE Catalog

CVE-2026-115918

MediumCVSS 6.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.35%

29th percentile - higher than 29% of all known CVEs

Summary

vLLM from 0.16.0 until 0.32.0 allows an authenticated caller to place an attacker-controlled template in chat_template_kwargs[chat_template] when no server template is configured. ChatParams.get_apply_chat_template_kwargs() preserves that value without enforcing trust_request_chat_template, bypassing the trust policy and causing CPU or memory exhaustion through Jinja rendering.

Risk Assessment

An authenticated attacker can cause resource exhaustion (CPU or memory) on the vLLM server, leading to denial of service for other users. The risk affects vLLM deployments with exposed API.

Recommendation

Update vLLM to version 0.32.0 or later. Consider restricting clients from supplying custom templates.

Other vulnerabilities in vLLM

See all
Original NVD description (English source)

vLLM is an inference and serving engine for large language models. From 0.16.0 until 0.32.0, the /v1/responses endpoint allows an authenticated caller to place an attacker-controlled template in chat_template_kwargs[chat_template] when no server template is configured. ChatParams.get_apply_chat_template_kwargs() preserves that value without enforcing trust_request_chat_template, so the request can bypass the intended trust policy and cause CPU or memory exhaustion through Jinja rendering. This issue is fixed in version 0.32.0.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS