CVE Catalog

CVE-2026-115914

MediumCVSS 6.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.40%

34th percentile - higher than 34% of all known CVEs

Summary

vLLM from 0.11.1 until 0.32.0, in the DeepSeek-OCR, DeepSeek-OCR-2, and Unlimited-OCR image path, allows a remote client reaching the OpenAI-compatible API to submit a legal image whose normalized pixels sum to zero when alone in its per-step encoder batch. _parse_and_validate_image_input returns no embedding, embed_multimodal propagates that value, and sanity_check_mm_encoder_outputs triggers a fatal assertion that shuts down the engine for all users.

Risk Assessment

A remote attacker can crash the entire vLLM engine, causing denial of service for all users. The risk affects vLLM deployments with OCR models and exposed API.

Recommendation

Update vLLM to version 0.32.0 or later. Restrict access to the OpenAI-compatible API for untrusted clients.

Other vulnerabilities in vLLM

See all
Original NVD description (English source)

vLLM is an inference and serving engine for large language models. From 0.11.1 until 0.32.0, the DeepSeek-OCR, DeepSeek-OCR-2, and Unlimited-OCR image path allows a remote client that can reach the OpenAI-compatible API to submit a legal image whose normalized pixels sum to zero when that image is alone in its per-step encoder batch. _parse_and_validate_image_input returns no embedding, embed_multimodal propagates that value, and sanity_check_mm_encoder_outputs triggers a fatal assertion that shuts down the engine for all users. This issue is fixed in version 0.32.0.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS