Katalog CVE

CVE-2026-97636

ŚrednieCVSS 6.5
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.21%

Percentyl 10 - wyżej niż 10% wszystkich znanych CVE

Streszczenie

W Apache Airflow HashiCorp provider występuje obejście zabezpieczenia zakresu zespołu w backendzie sekretów HashiCorp Vault. Autor DAG-a przypisany do jednego zespołu może podać klucz zmiennej zawierający separator ścieżki, co powoduje, że backend rozwiązuje sekret należący do innego zespołu. Podatność dotyczy wdrożeń wielozespołowych i jest osiągalna z poziomu zwykłego kodu DAG-a.

Ocena ryzyka

Atakujący z jednego zespołu może uzyskać dostęp do sekretów innych zespołów, co prowadzi do naruszenia izolacji i wycieku poufnych danych. Wdrożenia jednozespołowe nie są zagrożone.

Rekomendacja

Zaktualizuj pakiet apache-airflow-providers-hashicorp do wersji 4.8.0 lub nowszej, która naprawia tę podatność. Sprawdź, czy w Twoim środowisku nie występują nieautoryzowane próby dostępu do sekretów.

Powiązane podatności

Oryginalny opis (angielski, źródło NVD)

Apache Airflow HashiCorp provider: the HashiCorp Vault secrets backend's team-scope guard can be bypassed with a user-controlled key. In a multi-team deployment, a Dag author scoped to one team can supply a Variable key containing a path separator that causes the backend to resolve a secret belonging to a different team, because after the team-scoped lookup misses the backend falls back to a team-agnostic path concatenated from the unvalidated key. The Execution API Variables route accepts a path-shaped key, so this is reachable from ordinary Dag code. Affects multi-team deployments using the HashiCorp Vault secrets backend. Single-team deployments are not affected, as there is no cross-team boundary to cross. This is the same class as CVE-2026-86465, CVE-2026-68870, CVE-2026-68871 and CVE-2026-68872 in the Akeyless, Azure Key Vault, Yandex Lockbox and Amazon secrets backends. Users of apache-airflow-providers-hashicorp are recommended to upgrade to version 4.8.0 or later, which fixes the issue.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS