Katalog CVE

CVE-2026-7860

NiskieCVSS 1.6
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.12%

Percentyl 2 - wyżej niż 2% wszystkich znanych CVE

Streszczenie

Wtyczka Vaadin Maven oraz Vaadin Gradle ujawniają pełny zestaw zmiennych środowiskowych w logach budowania, gdy proces budowania frontendu zakończy się błędem (niezerowy status wyjścia). Ponieważ środowisko budowania może zawierać poświadczenia przekazywane jako sekrety, każdy nieudany build frontendu może ujawnić te sekrety w postaci jawnej w logach CI oraz archiwalnych artefaktach budowania.

Ocena ryzyka

Ujawnienie poświadczeń i innych sekretów z środowiska CI w logach oraz artefaktach budowania może umożliwić nieautoryzowany dostęp do systemów i usług organizacji. Ryzyko jest szczególnie wysokie, gdy logi CI są szeroko dostępne lub przechowywane długoterminowo.

Rekomendacja

Zaktualizuj wtyczki Vaadin do wersji naprawionych: 23.6.11, 24.9.18, 24.10.4, 25.0.12 lub 25.1.5 (w zależności od używanej gałęzi). Jeśli aktualizacja nie jest możliwa, rozważ rotację sekretów używanych w środowisku budowania oraz ograniczenie dostępu do logów CI.

Powiązane podatności

Oryginalny opis (angielski, źródło NVD)

A possible information disclosure vulnerability exists in the Vaadin Maven plugin and Vaadin Gradle plugin that exposes the full set of environment variables in build logs whenever the frontend build process exits with a non-zero status. Because the build environment may contain credentials supplied as secrets, any failed frontend build can expose those secrets in clear text in CI logs and archived build artifacts. Users of affected versions should apply the following mitigation or upgrade. Releases that have fixed this issue include: Product version Vaadin 23.0.0 - 23.6.9 Vaadin 24.0.0 - 24.9.16 Vaadin 24.10.0 - 24.10.3 Vaadin 25.0.0 - 25.0.10 Vaadin 25.1.0 - 25.1.4 Mitigation Upgrade to 23.6.10 Upgrade to 24.9.17 or newer Upgrade to 24.10.4 or newer Upgrade to 25.0.11 or newer Upgrade to 25.1.5 or newer Please note that Vaadin versions 10-13 and 15-22 are no longer supported and you should update either to the latest 23, 24, or 25 version. ArtifactsMaven coordinatesVulnerable versionsFixed versioncom.vaadin:flow-plugin-base23.0.0 - 23.6.10≥23.6.11com.vaadin:flow-plugin-base24.0.0 - 24.9.17≥24.9.18com.vaadin:flow-plugin-base24.10.0 - 24.10.3≥24.10.4com.vaadin:flow-plugin-base25.0.0 - 25.0.11≥25.0.12com.vaadin:flow-plugin-base25.1.0 - 25.1.4≥25.1.5com.vaadin:flow-maven-plugin23.0.0 - 23.6.10≥23.6.11com.vaadin:flow-maven-plugin24.0.0 - 24.9.17≥24.9.18com.vaadin:flow-maven-plugin24.10.0 - 24.10.3≥24.10.4com.vaadin:flow-maven-plugin25.0.0 - 25.0.11≥25.0.12com.vaadin:flow-maven-plugin25.1.0 - 25.1.4≥25.1.5com.vaadin:flow-gradle-plugin23.0.0 - 23.6.10≥23.6.11com.vaadin:flow-gradle-plugin24.0.0 - 24.9.17≥24.9.18com.vaadin:flow-gradle-plugin24.10.0 - 24.10.3≥24.10.4com.vaadin:flow-gradle-plugin25.0.0 - 25.0.11≥25.0.12com.vaadin:flow-gradle-plugin25.1.0 - 25.1.4≥25.1.5

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS