CVE-2026-63182
WysokieCVSS 8.1Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 4 - wyżej niż 4% wszystkich znanych CVE
Streszczenie
W bibliotece LightSAML przed wersjami 4.7.1 i 5.0.1 występuje niezgodność z xmlseclibs co do tego, którą asercję obejmuje podpis SAML. XMLSecurityDSig::validateReference() usuwa podpis z współdzielonego DOM, ale processRefNode() rozwiązuje Reference URI="#id" w całym dokumencie przez XPath //*[@Id] i bierze item(0), co nie musi być asercją, której dane LightSAML wykorzystuje. Atakujący z przechwyconą prawdziwie podpisaną asercją może umieścić jej bajty bez podpisu w samlp:Extensions i przedstawić sfałszowaną asercję z tym samym ID i skopiowanym podpisem, co umożliwia obejście uwierzytelniania lub eskalację uprawnień.
Ocena ryzyka
Może umożliwić obejście uwierzytelniania SAML lub eskalację uprawnień nawet przy wymaganej walidacji podpisu. Ryzyko dotyczy dostawców usług i tożsamości korzystających z LightSAML.
Rekomendacja
Zaktualizuj LightSAML do wersji 4.7.1 lub 5.0.1 (lub nowszej). Zweryfikuj konfigurację walidacji podpisów SAML i monitoruj nietypowe asercje.
Powiązane podatności
- CVE-2026-120534Krytyczne
Wtyczka Advanced Custom Fields: Extended PRO dla WordPressa jest podatna na ograniczoną iniekcję kodu w wersjach do 0.9.2.6 włącznie, poprzez funkcję render_field. Brak wystarczającej walidacji parametrów konfiguracji formularza pozwala nieuwierzytelnionym atakującym na wywoływanie dowolnych funkcji WordPressa z kontrolowanymi argumentami.
- CVE-2026-120518Krytyczne
Wtyczka BuddyPress XProfile Image Field dla WordPressa jest podatna na dowolne usuwanie plików w wersjach do 3.1.0 włącznie. Funkcja bpxp_image_field_update_on_user_activation() wywołuje unlink() na ścieżce zbudowanej z metadanych rejestracji dostarczonych przez odwiedzającego, bez rozwiązywania realpath(), sprawdzenia zawierania w katalogu profilowym i listy dozwolonych rozszerzeń.
- CVE-2026-86596Krytyczne
Wtyczka s2Member dla WordPressa w wersjach do 260927 włącznie jest podatna na zdalne wykonanie kodu poprzez parametr 'item_name'. Niedostateczna sanityzacja w funkcji strip_php_tags_deep() usuwa jedynie literalne sekwencje '<?', a późniejsze czyszczenie placeholderów po interpolacji odtwarza poprawny otwieracz '<?php' już po osadzeniu wartości kontrolowanej przez atakującego w szablonie e-mail.
- CVE-2026-97718Krytyczne
W wersji 14.60 serwera Secure Access występuje podatność typu cross-site request forgery (CSRF). Z powodu obejścia mechanizmu kontroli bezpieczeństwa atakujący może zmusić administratora do utworzenia konta pod kontrolą atakującego.
- CVE-2026-116769Krytyczne
W serwerach Secure Access w wersjach od 13.0 do wersji przed 14.61 występuje podatność polegająca na obejściu uwierzytelniania. Atakujący mogą modyfikować ustawienia bezpieczeństwa klienta za pośrednictwem serwera.
- CVE-2026-102435Krytyczne
Wtyczka Ultra Addons for Contact Form 7 dla WordPressa jest podatna na usuwanie dowolnych plików z powodu niewystarczającej walidacji ścieżki w funkcji _getObjAttr we wszystkich wersjach do 3.5.54 włącznie. Nieuwierzytelniony atakujący może usunąć dowolne pliki na serwerze, co może prowadzić do zdalnego wykonania kodu po usunięciu odpowiedniego pliku (np. wp-config.php). Wymaga to aktywnego dodatku PDF Generator i skonfigurowanego formularza Contact Form 7 do generowania PDF.
- CVE-2026-105606Krytyczne
Rozszerzenie Joomla Custom Tables w wersjach poniżej 3.7.8 pozwala nieuwierzytelnionemu atakującemu na przesłanie dowolnego pliku (typu polyglot) z kontrolowanym rozszerzeniem do publicznie dostępnego katalogu tmp. Ścieżka zapisanego pliku jest ujawniana w odpowiedzi, a plik jest domyślnie serwowany jako statyczna treść.
- CVE-2026-105604Krytyczne
Rozszerzenie Joomla DJ-Classifieds w wersjach poniżej 3.11.3 jest podatne na nieuwierzytelnioną iniekcję SQL w wyszukiwarce frontendowej.
- CVE-2026-105603Krytyczne
Rozszerzenie Joomla DJ-Classifieds w wersjach poniżej 3.11.3 pozwala nieuprzywilejowanemu użytkownikowi na przesłanie dowolnego pliku, co prowadzi do pełnego zdalnego wykonania kodu (RCE).
- CVE-2026-88811Krytyczne
Brak filtrowania w meta proxy SUSE Rancher Manager może powodować wyciek przekazanych poświadczeń Rancher do dostawców chmury. Problem dotyczy SUSE Rancher w wersjach 2.15.0–2.15.3, 2.14.0–2.14.7 oraz 2.13.0–2.13.11.
Oryginalny opis (angielski, źródło NVD)
LightSAML implements SAML 2.0 data model classes, XML serialization and deserialization, XML security, certificate support, and message bindings. Prior to 4.7.1 and 5.0.1, LightSAML and xmlseclibs disagree about which assertion an inbound SAML signature covers. `Response::deserialize` uses `manyElementsFromXml` to collect only direct-child `saml:Assertion` elements of `samlp:Response`, and `AssertionSignatureValidatorAction` validates their `ds:Signature` using an out-of-band trusted IdP credential resolved by Issuer, not a key from the document. `XMLSecurityDSig::validateReference()` removes the enveloped signature from the shared DOM, but `processRefNode()` resolves `Reference URI="#id"` document-wide through an XPath of the form `//*[@Id]` and takes `item(0)`, which need not be the assertion whose claims LightSAML consumes. An attacker who has captured one genuinely signed assertion, such as an earlier login response, can place its signature-stripped bytes earlier in `samlp:Extensions` and present a forged direct-child assertion with the same ID and copied genuine signature. Validation then covers the hidden genuine bytes while LightSAML surfaces unsigned attacker-controlled `Subject/NameID`, `Conditions`, and `Attributes`, enabling authentication bypass or privilege escalation even when signature validation is required. The behavior was confirmed in versions 5.0.0 and 4.6.1. This issue is fixed in versions 4.7.1 and 5.0.1.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

