CVE-2026-57196
NiskieCVSS 2.3Prawdopodobieństwo exploitacji (EPSS)
Podwyższone ryzykoPercentyl 55 - wyżej niż 55% wszystkich znanych CVE
Streszczenie
W Asterisk (open source PBX) przed wersjami 20.20.1, 21.12.3, 22.10.1, 23.4.1 oraz Certified Asterisk 20.7-cert11, 22.8-cert3 nieuwierzytelniony atakujący może wykorzystać odbity cross-site scripting w stronach błędów HTTP provisioningu telefonów, aby uzyskać ciasteczko sesji AMI uprawnionego użytkownika i podszyć się pod niego, gdy moduł res_phoneprov jest włączony. Wymagane jest włączenie serwera HTTP Asterisk, interfejsu AMI oraz dostępu AMI przez HTTP (domyślnie wyłączone), a także nakłonienie użytkownika do kliknięcia złośliwego linku.
Ocena ryzyka
Podszycie się pod uprawnionego użytkownika AMI może pozwolić atakującemu na wykonywanie operacji zarządzających centralą telefoniczną. Ryzyko występuje tylko przy włączonych określonych usługach, ale może prowadzić do poważnego naruszenia bezpieczeństwa.
Rekomendacja
Należy zaktualizować Asterisk do wersji 20.20.1, 21.12.3, 22.10.1, 23.4.1 lub Certified Asterisk 20.7-cert11, 22.8-cert3. Jeśli to możliwe, wyłączyć res_phoneprov oraz dostęp AMI przez HTTP.
Inne podatności w Asterisk
Zobacz wszystkie- CVE-2017-17850Wysokie
W Asterisk w wersjach 13.18.4 i starszych, 14.7.4 i starszych, 15.1.4 i starszych oraz 13.18-cert1 i starszych odkryto problem, który powoduje awarię systemu przy przetwarzaniu określonych wiadomości SIP bez nagłówka kontaktu. Problem występuje tylko, gdy używany jest sterownik kanału PJSIP.
- CVE-2017-14603Wysokie
W Asterisk 11.x przed wersją 11.25.3, 13.x przed wersją 13.17.2 oraz 14.x przed wersją 14.6.2 występuje niewystarczająca walidacja pakietów RTCP, co może prowadzić do odczytu przestarzałych zawartości bufora. W połączeniu z opcjami 'nat' i 'symmetric_rtp' może to umożliwić przekierowanie, gdzie Asterisk wysyła następny raport RTCP.
- CVE-2026-57203Średnie
Narzędzie ast_loggrabber w Asterisku wykonuje skrypt Pythona z katalogu /tmp, który jest zapisywalny dla wszystkich. Atakujący posiadający już sesję powłoki na serwerze może umieścić tam złośliwy skrypt i uzyskać podwyższone uprawnienia lub wykonać kod, gdy administrator uruchomi ast_loggrabber z podwyższonymi uprawnieniami.
- CVE-2026-57199Niskie
W pliku app_sms.c systemu Asterisk długości SMS kontrolowane z zewnątrz są kopiowane do buforów o stałym rozmiarze bez wystarczającej walidacji granic. Może to pozwolić atakującemu na uszkodzenie pamięci lub awarię Asteriska.
- CVE-2026-57192Średnie
W dekoderze Codec2 w Asterisku występuje zapis poza granicami bufora powodujący przepełnienie bufora sterty, wywołany niezgodnością liczby próbek floor/ceil. Uwierzytelniony atakujący może wykorzystać tę podatność, wysyłając spreparowane pakiety audio Codec2 w ramach ustanowionej rozmowy.
- CVE-2026-57191Wysokie
W module res_pjsip_pubsub systemu Asterisk występuje nieograniczone wywołanie sscanf podczas parsowania pola Message-Account w komunikacie MWI NOTIFY. Nieuwierzytelniony atakujący może wysłać spreparowany pakiet powodujący przepełnienie bufora stosu i uszkodzenie transportu, trwale wyłączając funkcje SIP do czasu restartu.
- CVE-2026-57190Wysokie
Backendy cel_pgsql i cel_tds (PostgreSQL oraz TDS/MSSQL) w Asterisku mogą umożliwić wykonanie dowolnego SQL, gdy niezaufane dane zostaną ustawione w kolumnie eventtype CEL przez aplikację dialplanu CELGenUserEvent. Wymagane jest załadowanie i skonfigurowanie backendu oraz wywołanie CELGenUserEvent bez walidacji danych.
- CVE-2026-57186Wysokie
W sterowniku kanału chan_ooh323 parser numeru strony Q.931 nie zawiera poprawki CVE-2022-37325, która nie została przeniesiona z Asterisk 20 do nowszych wersji. Zniekształcone elementy Q.931 w żądaniu OOH323 mogą spowodować awarię Asteriska.
- CVE-2026-57200Wysokie
W Asterisk przed wersjami 20.20.1, 21.12.3, 22.10.1, 23.4.1 i Certified Asterisk 22.8-cert3 uwierzytelniony atakujący z uprawnieniami tylko do odczytu w Asterisk REST Interface (ARI) może w pewnych warunkach wykonywać operacje zapisu przez REST-over-WebSocket. Obejście autoryzacji umożliwia ładowanie dowolnej ścieżki modułu i warunkowe zdalne wykonanie kodu.
- CVE-2026-57195Wysokie
W Asterisk przed wersjami 20.20.1, 21.12.3, 22.10.1, 23.4.1 oraz Certified Asterisk 20.7-cert11 i 22.8-cert3 występuje dereferencja wskaźnika NULL w Asterisk Manager Interface (AMI). Nieuwierzytelniony atakujący może doprowadzić do awarii Asterisk, gdy używane jest uwierzytelnianie Digest przez HTTP.
Oryginalny opis (angielski, źródło NVD)
Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, an unauthenticated attacker may use reflected cross-site scripting in `phone provisioning HTTP error pages` to retrieve an authorized user's `AMI session cookie` and impersonate that user when `res_phoneprov` is enabled. The Asterisk HTTP web server, Asterisk Manager Interface (AMI), and AMI access via HTTP must all be enabled; each is disabled by default. The attacker must be able to connect to the HTTP server, which binds only to `127.0.0.1` by default even when enabled, and must convince the authorized user to click a malicious link. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

