CVE-2026-57152
WysokieCVSS 7.1Streszczenie
W GLPI od wersji 0.85 do 10.0.26 oraz od 11.0.0 do 11.0.8 logika uprawnień mogła przyznać użytkownikowi dostęp do dokumentu bez potwierdzenia, że dokument jest powiązany z docelowym elementem. Może to ujawnić plik użytkownikowi, który nie powinien mieć do niego dostępu.
Ocena ryzyka
Użytkownik bez odpowiednich uprawnień może uzyskać dostęp do poufnych dokumentów, co prowadzi do naruszenia poufności. Ryzyko dotyczy organizacji przechowujących wrażliwe pliki w GLPI.
Rekomendacja
Zaktualizuj GLPI do wersji 10.0.26 lub 11.0.8 (lub nowszej). Przejrzyj uprawnienia dostępu do dokumentów w swojej instancji.
Inne podatności w GLPI
Zobacz wszystkie- CVE-2026-53631Średnie
W GLPI każdy uwierzytelniony użytkownik mógł przesłać spreparowane żądanie zmiany widoczności elementów bazy wiedzy, przypomnień lub kanałów RSS, a następnie uzyskać dostęp do treści, które powinny pozostać ograniczone. Podatność występuje od wersji 0.83 do 10.0.27 oraz od 11.0.0 do 11.0.9.
- CVE-2026-47678Wysokie
W GLPI od wersji 9.4.0 do 10.0.26 oraz w 11.0.8 każdy uwierzytelniony użytkownik może przesłać spreparowane wartości do endpointu pobierania wartości list rozwijanych, które są włączane do zapytania do bazy danych. Umożliwia to wstrzyknięcie SQL przez endpoint list rozwijanych.
- CVE-2025-66417Wysokie
GLPI to darmowe oprogramowanie do zarządzania zasobami i IT. W wersjach od 11.0.0 do 11.0.2 (przed 11.0.3) nieuwierzytelniony użytkownik może przeprowadzić atak SQL injection przez endpoint inwentaryzacji. Luka została naprawiona w wersji 11.0.3.
- CVE-2025-64516Wysokie
GLPI przed wersjami 10.0.21 i 11.0.3 umożliwia nieautoryzowanemu użytkownikowi dostęp do dokumentów GLPI przypisanych do dowolnego elementu (zgłoszenia, zasobu itp.). Jeśli publiczna FAQ jest włączona, dostęp ten może być wykonany przez anonimowego użytkownika. Poprawka znajduje się w wersjach 10.0.21 i 11.0.3.
- CVE-2017-11475Wysokie
GLPI w wersjach przed 9.1.5.1 zawiera podatność na wstrzykiwanie SQL w polu reguły warunkowej, którą można wykorzystać poprzez front/rulesengine.test.php.
- CVE-2016-7507Wysokie
Podatność typu Cross-Site Request Forgery (CSRF) w GLPI 0.90.4 umożliwia zdalnym, uwierzytelnionym atakującym wysłanie żądania, które może prowadzić do utworzenia konta administratora w aplikacji.
- CVE-2016-7508Wysokie
Wielokrotne podatności na wstrzykiwanie SQL w GLPI 0.90.4 umożliwiają uwierzytelnionemu zdalnemu atakującemu wykonanie dowolnych poleceń SQL przy użyciu określonego znaku, gdy baza danych jest skonfigurowana do używania kodowania Big5.
- CVE-2015-7684Wysokie
W GLPI przed wersją 0.85.3 występuje podatność na nieograniczone przesyłanie plików, która pozwala zdalnym uwierzytelnionym użytkownikom na wykonanie dowolnego kodu poprzez dodanie pliku z rozszerzeniem wykonywalnym jako załącznika do nowego zgłoszenia.
- CVE-2014-8360Wysokie
Podatność na przejście katalogu w pliku inc/autoload.function.php w GLPI przed wersją 0.84.8 umożliwia zdalnym atakującym dołączanie i wykonywanie dowolnych lokalnych plików poprzez użycie sekwencji .._ (kropka kropka podkreślnik) w typie elementu przekazywanym do funkcji getItemForItemtype.
- CVE-2013-2226Wysokie
Wielokrotne podatności na wstrzykiwanie SQL w GLPI przed wersją 0.83.9 umożliwiają zdalnym atakującym wykonywanie dowolnych poleceń SQL poprzez różne parametry w aplikacji.
Oryginalny opis (angielski, źródło NVD)
GLPI is a free asset and IT management software package. From 0.85 until 10.0.26 and from 11.0.0 until 11.0.8, under certain conditions, GLPI permission logic could grant a user access to a document without confirming that the document was linked to the targeted item. This could expose the file to a user who should not be able to view it. This issue is fixed in versions 10.0.26 and 11.0.8.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

