CVE-2026-54552
WysokieCVSS 7.9Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 6 - wyżej niż 6% wszystkich znanych CVE
Streszczenie
Biblioteka sh przed wersją 2.2.4 niekompletnie obniża uprawnienia przy użyciu opcji _uid na systemach Linux i Unix. Uruchomiony proces z podniesionymi uprawnieniami może zachować grupy dodatkowe rodzica, co pozwala dziecku na dostęp do plików i zasobów zarezerwowanych dla grup uprzywilejowanych, takich jak root, docker, disk, shadow czy sudo.
Ocena ryzyka
Organizacja narażona jest na eskalację uprawnień, ponieważ proces uruchamiany z niższym UID może nadal mieć dostęp do wrażliwych zasobów systemowych, co może prowadzić do nieautoryzowanego dostępu do danych lub przejęcia kontroli nad systemem.
Rekomendacja
Zaleca się natychmiastową aktualizację biblioteki sh do wersji 2.2.4 lub nowszej, która w pełni implementuje opuszczanie uprawnień.
Powiązane podatności
- CVE-2026-120534Krytyczne
Wtyczka Advanced Custom Fields: Extended PRO dla WordPressa jest podatna na ograniczoną iniekcję kodu w wersjach do 0.9.2.6 włącznie, poprzez funkcję render_field. Brak wystarczającej walidacji parametrów konfiguracji formularza pozwala nieuwierzytelnionym atakującym na wywoływanie dowolnych funkcji WordPressa z kontrolowanymi argumentami.
- CVE-2026-120518Krytyczne
Wtyczka BuddyPress XProfile Image Field dla WordPressa jest podatna na dowolne usuwanie plików w wersjach do 3.1.0 włącznie. Funkcja bpxp_image_field_update_on_user_activation() wywołuje unlink() na ścieżce zbudowanej z metadanych rejestracji dostarczonych przez odwiedzającego, bez rozwiązywania realpath(), sprawdzenia zawierania w katalogu profilowym i listy dozwolonych rozszerzeń.
- CVE-2026-86596Krytyczne
Wtyczka s2Member dla WordPressa w wersjach do 260927 włącznie jest podatna na zdalne wykonanie kodu poprzez parametr 'item_name'. Niedostateczna sanityzacja w funkcji strip_php_tags_deep() usuwa jedynie literalne sekwencje '<?', a późniejsze czyszczenie placeholderów po interpolacji odtwarza poprawny otwieracz '<?php' już po osadzeniu wartości kontrolowanej przez atakującego w szablonie e-mail.
- CVE-2026-97718Krytyczne
W wersji 14.60 serwera Secure Access występuje podatność typu cross-site request forgery (CSRF). Z powodu obejścia mechanizmu kontroli bezpieczeństwa atakujący może zmusić administratora do utworzenia konta pod kontrolą atakującego.
- CVE-2026-116769Krytyczne
W serwerach Secure Access w wersjach od 13.0 do wersji przed 14.61 występuje podatność polegająca na obejściu uwierzytelniania. Atakujący mogą modyfikować ustawienia bezpieczeństwa klienta za pośrednictwem serwera.
- CVE-2026-102435Krytyczne
Wtyczka Ultra Addons for Contact Form 7 dla WordPressa jest podatna na usuwanie dowolnych plików z powodu niewystarczającej walidacji ścieżki w funkcji _getObjAttr we wszystkich wersjach do 3.5.54 włącznie. Nieuwierzytelniony atakujący może usunąć dowolne pliki na serwerze, co może prowadzić do zdalnego wykonania kodu po usunięciu odpowiedniego pliku (np. wp-config.php). Wymaga to aktywnego dodatku PDF Generator i skonfigurowanego formularza Contact Form 7 do generowania PDF.
- CVE-2026-105606Krytyczne
Rozszerzenie Joomla Custom Tables w wersjach poniżej 3.7.8 pozwala nieuwierzytelnionemu atakującemu na przesłanie dowolnego pliku (typu polyglot) z kontrolowanym rozszerzeniem do publicznie dostępnego katalogu tmp. Ścieżka zapisanego pliku jest ujawniana w odpowiedzi, a plik jest domyślnie serwowany jako statyczna treść.
- CVE-2026-105604Krytyczne
Rozszerzenie Joomla DJ-Classifieds w wersjach poniżej 3.11.3 jest podatne na nieuwierzytelnioną iniekcję SQL w wyszukiwarce frontendowej.
- CVE-2026-105603Krytyczne
Rozszerzenie Joomla DJ-Classifieds w wersjach poniżej 3.11.3 pozwala nieuprzywilejowanemu użytkownikowi na przesłanie dowolnego pliku, co prowadzi do pełnego zdalnego wykonania kodu (RCE).
- CVE-2026-88811Krytyczne
Brak filtrowania w meta proxy SUSE Rancher Manager może powodować wyciek przekazanych poświadczeń Rancher do dostawców chmury. Problem dotyczy SUSE Rancher w wersjach 2.15.0–2.15.3, 2.14.0–2.14.7 oraz 2.13.0–2.13.11.
Oryginalny opis (angielski, źródło NVD)
sh provides Python process launching. Prior to 2.2.4, the _uid option in sh.py performs an incomplete privilege drop on Linux and Unix-like systems. When sh runs from an elevated process and launches a command with _uid set to an unprivileged user, the child changes its UID but can retain the parent process's supplementary groups because the privilege-drop sequence does not fully establish the target user's UID, primary GID, and supplementary groups. The child can therefore retain access to files or resources granted to privileged groups such as root, docker, disk, shadow, or sudo, violating the expected _uid privilege boundary. This issue is fixed in version 2.2.4.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

