Katalog CVE

CVE-2026-54239

WysokieCVSS 8.8
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.32%

Percentyl 23 - wyżej niż 23% wszystkich znanych CVE

Streszczenie

W wtyczce FaustWP dla WordPressa przed wersją 1.8.11 uwierzytelniany jest tylko szyfrogram w kopercie tokenu, a 16-bajtowy wektor inicjalizacyjny jest wyłączony z HMAC. Zalogowany użytkownik niebędący administratorem, który uzyska kod autoryzacyjny z GET /generate, może zmodyfikować nieuwierzytelniony wektor inicjalizacyjny tak, aby odszyfrowanie CBC zmieniło typ tokenu i identyfikator użytkownika przy zachowaniu ważnego HMAC. Może to pozwolić na uzyskanie tokenu dostępu administratora i pełny dostęp do REST API WordPressa, tworzenie kont administratorów, instalację wtyczek i wykonanie dowolnego kodu. Podatność została naprawiona w wersji 1.8.11.

Ocena ryzyka

Atakujący z uprawnieniami zalogowanego użytkownika może eskalować uprawnienia do administratora i przejąć pełną kontrolę nad witryną WordPress, w tym wykonać dowolny kod. Może to prowadzić do całkowitego przejęcia serwisu i danych.

Rekomendacja

Zaktualizuj wtyczkę FaustWP do wersji 1.8.11 lub nowszej. Do czasu aktualizacji ogranicz możliwość uzyskiwania kodów autoryzacyjnych przez użytkowników o niskich uprawnieniach.

Powiązane podatności

Oryginalny opis (angielski, źródło NVD)

Faust.js is a headless WordPress toolkit. Prior to 1.8.11, the FaustWP WordPress plugin authenticates only the ciphertext in its token envelope and excludes the 16-byte initialization vector from the HMAC in WPE\FaustWP\Auth\encrypt() and WPE\FaustWP\Auth\decrypt() in plugins/faustwp/includes/auth/functions.php. A logged-in non-administrator who obtains an authorization code from GET /generate can modify the unauthenticated initialization vector so that CBC decryption changes the token type and user identifier while the HMAC remains valid. This can produce an access token for an Administrator and permit full WordPress REST API access, administrator-account creation, plugin installation, and arbitrary code execution. This issue is fixed in repository version 1.8.11.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS