Katalog CVE

CVE-2026-45205

ŚrednieCVSS 5.3
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.47%

Percentyl 40 - wyżej niż 40% wszystkich znanych CVE

Streszczenie

Apache Commons Configuration od wersji 2.2 przed 2.15.0 zawiera podatność niekontrolowanej rekurencji. Przetwarzanie niezaufanego pliku konfiguracyjnego YAML z cyklami powoduje StackOverflowError. Problem naprawiono w wersji 2.15.0.

Ocena ryzyka

Atakujący może dostarczyć złośliwy plik YAML, powodując wyczerpanie stosu i awarię aplikacji, co prowadzi do odmowy usługi. Ryzyko dotyczy aplikacji przetwarzających niezaufane konfiguracje YAML.

Rekomendacja

Zaktualizuj Apache Commons Configuration do wersji 2.15.0 lub nowszej. Do czasu aktualizacji unikaj przetwarzania niezaufanych plików YAML.

Powiązane podatności

Oryginalny opis (angielski, źródło NVD)

Uncontrolled Recursion vulnerability in Apache Commons. When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles. This issue affects Apache Commons: from 2.2 before 2.15.0. Users are recommended to upgrade to version 2.15.0, which fixes the issue.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS