CVE-2026-44681
ŚrednieCVSS 6.1Streszczenie
Authlib to biblioteka Pythona, która buduje serwery OAuth i OpenID Connect. W wersjach przed 1.6.12 i 1.7.1 występowała nieautoryzowana otwarta przekierowanie w punkcie autoryzacji OpenIDImplicitGrant i OpenIDHybridGrant, co pozwalało zdalnemu atakującemu na wymuszenie wydania przez serwer autoryzacji HTTP 302 do wybranego przez atakującego adresu URL.
Ocena ryzyka
Wykorzystanie tej podatności może prowadzić do nieautoryzowanego przekierowania użytkowników na złośliwe strony, co stwarza ryzyko kradzieży danych lub oszustw. Organizacje mogą być narażone na utratę zaufania użytkowników oraz potencjalne straty finansowe.
Rekomendacja
Zaleca się aktualizację biblioteki Authlib do wersji 1.6.12 lub 1.7.1, aby usunąć tę podatność. Dodatkowo warto przeprowadzić audyt bezpieczeństwa aplikacji korzystających z tej biblioteki.
Powiązane podatności
- CVE-2026-6715Krytyczne
IBM Concert w wersjach 1.0 do 3.0.1.1 pozwala atakującemu dostarczyć spreparowane dane wejściowe, które trafiają do polecenia systemu operacyjnego bez odpowiedniej walidacji lub sanityzacji. Skuteczne wykorzystanie umożliwia zdalnym atakującym wykonanie dowolnych poleceń w systemie operacyjnym z uprawnieniami usługi.
- CVE-2026-17466Krytyczne
IBM Optim w wersjach 1.0.0, 1.1.0 i 1.2.0 jest podatny na atak path traversal, który umożliwia zdalnemu uwierzytelnionemu atakującemu uzyskanie dostępu do poufnych informacji.
- CVE-2026-15266Krytyczne
IBM Concert w wersjach od 1.0 do 3.0.1.1 zawiera komponenty umożliwiające potencjalnie niebezpieczne wykonanie poleceń, co może zostać wykorzystane do uruchomienia dowolnych poleceń systemowych na hoście.
- CVE-2026-114464Krytyczne
IBM Process Mining w wersjach 2.0.0 do 2.2.1 ma nieprawidłową kontrolę dostępu, co może pozwolić zdalnemu atakującemu na uzyskanie dostępu do poufnych informacji.
- CVE-2026-107331Krytyczne
IBM DataStage w Cloud Pak for Data 5.4.0.0 ma podatność typu absolute-path traversal, która może pozwolić zdalnemu uwierzytelnionemu atakującemu na uzyskanie dostępu do poufnych informacji.
- CVE-2026-109900Krytyczne
Wtyczka Melapress Role Editor do WordPressa (do wersji 1.3.0) zawiera błąd nieprawidłowego przypisania uprawnień, który umożliwia eskalację przywilejów. Użytkownik o niskich uprawnieniach może uzyskać wyższy poziom dostępu w systemie.
- CVE-2026-101117Krytyczne
IBM WebSphere Extreme Scale w wersjach od 8.6.1.0 do 8.6.2.2 ma nieprawidłową konfigurację Content Security Policy, co może pozwolić zdalnemu atakującemu na obejście ograniczeń bezpieczeństwa. Luka dotyczy mechanizmów ochronnych przeglądarki.
- CVE-2026-124494Krytyczne
SunEditor w wersji przed 3.4.0 zawiera podatność typu stored XSS, ponieważ funkcja _normalizeURL() w sanitizerze html.clean() dekoduje encje nazwane, takie jak :, do pustego ciągu. Atakujący mogą wstrzyknąć wartości href, np. javascript:, które przechodzą kontrolę _isSafeURL(), ale są dekodowane przez przeglądarki, co prowadzi do wykonania JavaScriptu po kliknięciu zapisanego linku.
- CVE-2026-124493Krytyczne
SunEditor w wersji przed 3.4.0 zawiera podatność typu stored XSS w konstruktorze DocumentType, który wstrzykuje tekst nagłówka do innerHTML bez escapowania HTML. Atakujący mogą zapisać zakodowany encjami HTML w nagłówkach h1-h6, który wykonuje JavaScript podczas inicjalizacji edytorów w trybie document:header, umożliwiając kradzież ciasteczek sesyjnych.
- CVE-2026-124490Krytyczne
OpenEMR w wersji przed 8.3.0 zawiera podatność typu path traversal w metodzie disposeDocument() klasy RingCentral RCFaxClient modułu oe-module-faxsms, która pozwala uwierzytelnionym atakującym odczytywać i zapisywać dowolne pliki poprzez parametr file_path. Atakujący mogą użyć action=download do odczytu danych uwierzytelniających i kodu źródłowego lub action=setup z zawartością base64 do zapisu plików wykonywalnych przez serwer WWW, co umożliwia wykonanie kodu.
Oryginalny opis (angielski, źródło NVD)
Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to 1.6.12 and 1.7.1, an unauthenticated open redirect in Authlib's OpenIDImplicitGrant and OpenIDHybridGrant authorization endpoint lets a remote attacker cause the authorization server to issue an HTTP 302 to an attacker-chosen URL by submitting an authorization request that omits the openid scope. This vulnerability is fixed in 1.6.12 and 1.7.1.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

