Katalog CVE

CVE-2026-41043

ŚrednieCVSS 6.5
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.56%

Percentyl 46 - wyżej niż 46% wszystkich znanych CVE

Streszczenie

Apache ActiveMQ i ActiveMQ Web zawierają podatność Basic XSS polegającą na niewłaściwej neutralizacji tagów HTML w konsoli webowej. Uwierzytelniony atakujący może wyświetlić złośliwą treść podczas przeglądania kolejek, nadpisując typ zawartości na HTML i wstrzykując HTML w pole selektora JMS. Problem dotyczy wersji przed 5.19.6 oraz 6.0.0–6.2.5.

Ocena ryzyka

Uwierzytelniony atakujący może wykonać skrypt w przeglądarce innych użytkowników konsoli, co może prowadzić do kradzieży sesji lub działań w ich imieniu. Wymaga konta w ActiveMQ, ale może eskalować uprawnienia.

Rekomendacja

Zaktualizuj Apache ActiveMQ i ActiveMQ Web do wersji 6.2.5 lub 5.19.6 (lub nowszej). Ogranicz dostęp do konsoli webowej do zaufanych sieci.

Inne podatności w Apache ActiveMQ

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache ActiveMQ, Apache ActiveMQ Web. An authenticated attacker can show malicious content when browsing queues in the web console by overriding the content type to be HTML (instead of XML) and by injecting HTML into a JMS selector field. This issue affects Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ Web: before 5.19.6, from 6.0.0 before 6.2.5. Users are recommended to upgrade to version 6.2.5 or 5.19.6, which fixes the issue.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS