Katalog CVE

CVE-2026-33227

ŚrednieCVSS 4.3
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.42%

Percentyl 36 - wyżej niż 36% wszystkich znanych CVE

Streszczenie

Apache ActiveMQ zawiera lukę niewłaściwej walidacji nazw ścieżek classpath. Uwierzytelniony użytkownik może podać wartość 'key', która po konkatenacji ścieżek pozwala na traversal classpath, co może prowadzić do ładowania zasobów spoza dozwolonego obszaru i łączenia z innymi atakami.

Ocena ryzyka

Uwierzytelniony atakujący może wykorzystać lukę do załadowania nieautoryzowanych zasobów classpath, co potencjalnie umożliwia dalszą eksploatację w połączeniu z innymi podatnościami.

Rekomendacja

Zaktualizuj Apache ActiveMQ do wersji 5.19.4 lub 6.2.3 (lub nowszej). Upewnij się, że poprawka jest zastosowana również w środowiskach Windows.

Inne podatności w Apache ActiveMQ

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

Improper validation and restriction of a classpath path name vulnerability in Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ Web, Apache ActiveMQ. In two instances (when creating a Stomp consumer and also browsing messages in the Web console) an authenticated user provided "key" value could be constructed to traverse the classpath due to path concatenation. As a result, the application is exposed to a classpath path resource loading vulnerability that could potentially be chained together with another attack to lead to exploit. This issue affects Apache ActiveMQ Client: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ Broker: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ All: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ Web: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ: before 5.19.3, from 6.0.0 before 6.2.2. Users are recommended to upgrade to version 5.19.4 or 6.2.3, which fixes the issue. Note: 5.19.3 and 6.2.2 also fix this issue, but that is limited to non-Windows environments due to a path separator resolution bug fixed in 5.19.4 and 6.2.3.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS