Katalog CVE

CVE-2026-26929

ŚrednieCVSS 6.5
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.42%

Percentyl 37 - wyżej niż 37% wszystkich znanych CVE

Streszczenie

Apache Airflow w wersjach 3.0.0–3.1.7 API FastAPI do listowania wersji DAG-ów nie stosuje filtrowania autoryzacji per DAG, gdy żądanie zawiera dag_id ustawione na "~" (symbol wieloznaczny dla wszystkich DAG-ów). W rezultacie zwracane są metadane wersji DAG-ów, do których żądający nie ma uprawnień.

Ocena ryzyka

Może to ujawnić informacje o wersjach i istnieniu DAG-ów użytkownikom bez odpowiednich uprawnień, co narusza kontrolę dostępu.

Rekomendacja

Zaktualizuj Apache Airflow do wersji 3.1.8 lub nowszej.

Inne podatności w Apache Airflow

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

Apache Airflow versions 3.0.0 through 3.1.7 FastAPI DagVersion listing API does not apply per-DAG authorization filtering when the request is made with dag_id set to "~" (wildcard for all DAGs). As a result, version metadata of DAGs that the requester is not authorized to access is returned. Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS