CVE-2026-117549
ŚrednieCVSS 4.2Streszczenie
Wtyczka @fastify/secure-session w wersjach 7.5.0–8.4.1, gdy skonfigurowana z opcją podpisanego ciasteczka, wywołuje procedurę unsign, ale gdy weryfikacja podpisu zgłasza nieprawidłowość, nadal przekazuje oryginalną wartość ciasteczka do dekodera sesji, więc sesja z nieprawidłowym podpisem jest odszyfrowywana. Ma to znaczenie, gdy aplikacja używa osobnego sekretu podpisywania i rotuje tylko ten sekret, aby wycofać sesje, zachowując klucz szyfrowania.
Ocena ryzyka
Posiadacz starego ciasteczka sesji może usunąć nieaktualny podpis i nadal korzystać z sesji, co narusza oczekiwane unieważnienie sesji. Atakujący musi już posiadać nieprzeterminowane zaszyfrowane ciasteczko sesji i nie może sfałszować danych sesji ani wydłużyć ważności.
Rekomendacja
Zaktualizuj @fastify/secure-session do wersji 8.4.2 lub nowszej. Jako obejście rotuj klucz szyfrowania sesji zamiast polegać wyłącznie na rotacji sekretu podpisywania ciasteczka.
Powiązane podatności
- CVE-2026-86596Krytyczne
Wtyczka s2Member dla WordPressa w wersjach do 260927 włącznie jest podatna na zdalne wykonanie kodu poprzez parametr 'item_name'. Niedostateczna sanityzacja w funkcji strip_php_tags_deep() usuwa jedynie literalne sekwencje '<?', a późniejsze czyszczenie placeholderów po interpolacji odtwarza poprawny otwieracz '<?php' już po osadzeniu wartości kontrolowanej przez atakującego w szablonie e-mail.
- CVE-2026-97718Krytyczne
W wersji 14.60 serwera Secure Access występuje podatność typu cross-site request forgery (CSRF). Z powodu obejścia mechanizmu kontroli bezpieczeństwa atakujący może zmusić administratora do utworzenia konta pod kontrolą atakującego.
- CVE-2026-116769Krytyczne
W serwerach Secure Access w wersjach od 13.0 do wersji przed 14.61 występuje podatność polegająca na obejściu uwierzytelniania. Atakujący mogą modyfikować ustawienia bezpieczeństwa klienta za pośrednictwem serwera.
- CVE-2026-102435Krytyczne
Wtyczka Ultra Addons for Contact Form 7 dla WordPressa jest podatna na usuwanie dowolnych plików z powodu niewystarczającej walidacji ścieżki w funkcji _getObjAttr we wszystkich wersjach do 3.5.54 włącznie. Nieuwierzytelniony atakujący może usunąć dowolne pliki na serwerze, co może prowadzić do zdalnego wykonania kodu po usunięciu odpowiedniego pliku (np. wp-config.php). Wymaga to aktywnego dodatku PDF Generator i skonfigurowanego formularza Contact Form 7 do generowania PDF.
- CVE-2026-105606Krytyczne
Rozszerzenie Joomla Custom Tables w wersjach poniżej 3.7.8 pozwala nieuwierzytelnionemu atakującemu na przesłanie dowolnego pliku (typu polyglot) z kontrolowanym rozszerzeniem do publicznie dostępnego katalogu tmp. Ścieżka zapisanego pliku jest ujawniana w odpowiedzi, a plik jest domyślnie serwowany jako statyczna treść.
- CVE-2026-105604Krytyczne
Rozszerzenie Joomla DJ-Classifieds w wersjach poniżej 3.11.3 jest podatne na nieuwierzytelnioną iniekcję SQL w wyszukiwarce frontendowej.
- CVE-2026-105603Krytyczne
Rozszerzenie Joomla DJ-Classifieds w wersjach poniżej 3.11.3 pozwala nieuprzywilejowanemu użytkownikowi na przesłanie dowolnego pliku, co prowadzi do pełnego zdalnego wykonania kodu (RCE).
- CVE-2026-88811Krytyczne
Brak filtrowania w meta proxy SUSE Rancher Manager może powodować wyciek przekazanych poświadczeń Rancher do dostawców chmury. Problem dotyczy SUSE Rancher w wersjach 2.15.0–2.15.3, 2.14.0–2.14.7 oraz 2.13.0–2.13.11.
- CVE-2026-105769Krytyczne
kaniko przed wersją 1.25.20 może wysłać token dostępu Microsoft Entra ID (Azure AD) dla Azure Resource Manager do rejestru kontrolowanego przez atakującego. Wynika to z niezakotwiczonego wyrażenia regularnego w pomocniku poświadczeń ACR, które akceptuje nazwy hostów zawierające domeny .azurecr.io, .azurecr.cn, .azurecr.de lub .azurecr.us.
- CVE-2026-94290Krytyczne
Kontroler SUSE Rancher Fleet nie ograniczał wystarczająco, które sekrety kubeconfig może przywoływać obiekt Fleet Cluster. W efekcie zwykły użytkownik mógł zdefiniować klaster w swojej przestrzeni nazw i powiązać go z poświadczeniami administracyjnymi klastra zarządzającego, co pozwalało kontrolerowi zarządzać klastrem zarządzającym w imieniu tego użytkownika z podwyższonymi uprawnieniami. Podatność dotyczy wersji 0.16.0–0.16.3, 0.15.0–0.15.8, 0.14.0–0.14.12, 0.13.0–0.13.17 i prawdopodobnie starszych.
Oryginalny opis (angielski, źródło NVD)
@fastify/secure-session is a session plugin for Fastify that stores an encrypted session in a cookie. In versions 7.5.0 through 8.4.1, when the plugin is configured with the signed cookie option, it calls the cookie unsign routine but, when the signature check reports the value as invalid, still passes the original cookie value to the session decoder, so a session whose signature did not validate is decrypted anyway. The practical effect appears when an application supplies the cookie signing secret independently of the session encryption key and rotates only the signing secret to retire existing sessions while keeping the encryption key active, because a holder of an old session cookie can strip the now obsolete signature and keep using the session. The attacker must already possess an unexpired encrypted session cookie and needs neither secret, and cannot forge session data, extend expiry, or survive rotation of the encryption key. The issue is fixed in @fastify/secure-session 8.4.2, which no longer decodes the session when the signed cookie option is set and the signature check fails, and users should upgrade to 8.4.2 or later. As a workaround, rotate the session encryption key rather than relying on rotation of the cookie signing secret alone.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

