CVE-2026-115415
ŚrednieCVSS 6.5Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 28 - wyżej niż 28% wszystkich znanych CVE
Streszczenie
Niewłaściwa neutralizacja danych wejściowych używanych do promptów LLM w narzędziu environment w Strands Agents Tools przed wersją 0.8.6 może pozwolić zdalnym aktorom na uzyskanie w postaci jawnej zmiennych środowiskowych hosta agenta, w tym poświadczeń chmurowych i kluczy API, poprzez spreparowany prompt wyłączający maskowanie sekretów w narzędziu. Aby usunąć problem, należy zaktualizować do wersji 0.8.6 lub nowszej i wymienić poświadczenia, które były obecne w środowisku agentów ładujących narzędzie environment.
Ocena ryzyka
Wyciek poświadczeń chmurowych i kluczy API może umożliwić nieautoryzowany dostęp do zasobów i usług organizacji.
Rekomendacja
Zaktualizuj Strands Agents Tools do wersji 0.8.6 lub nowszej oraz natychmiast wymień wszystkie poświadczenia i klucze API, które mogły być dostępne w środowisku agentów.
Inne podatności w Strands Agents Tools
Zobacz wszystkie- CVE-2026-18394Wysokie
W Strands Agents Tools przed wersją 0.8.2 występuje nieprawidłowa autoryzacja w narzędziu http_request, która może pozwolić zdalnym atakującym na uzyskanie poświadczeń skonfigurowanych przez HTTP_REQUEST_TOKEN_CONFIG poprzez nakłonienie LLM do kierowania żądań przez infrastrukturę proxy kontrolowaną przez atakującego.
- CVE-2026-15746Średnie
W narzędziu elasticsearch_memory pakietu strands-agents-tools wykryto podatność SSRF. Parametry połączenia (es_url, cloud_id, api_key) były kontrolowane przez model językowy, a pominięcie api_key powodowało wysłanie klucza API operatora do dowolnego hosta wskazanego przez LLM.
Oryginalny opis (angielski, źródło NVD)
Improper neutralization of input used for LLM prompting in the environment tool in Strands Agents Tools before 0.8.6 might allow remote actors to obtain the agent host's environment variables in cleartext, including cloud credentials and API keys, via a crafted prompt that disables the tool's secret masking. To remediate this issue, users should upgrade to version 0.8.6 or later and rotate any credentials that were present in the environment of agents that loaded the environment tool.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

