Katalog CVE

CVE-2026-108358

WysokieCVSS 8.8
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.39%

Percentyl 31 - wyżej niż 31% wszystkich znanych CVE

Streszczenie

W bibliotece PhpSpreadsheet przed wersjami 1.30.7, 2.1.19, 2.4.8, 3.10.8 i 5.10.0 funkcja XmlScanner::scan wykrywa DOCTYPE z uwzględnieniem bajtów NUL, ale nie sekwencji ucieczki ISO-2022 w częściach XML plików XLSX. Sekwencje te omijają skaner, a normalizacja kodowania usuwa bajty ucieczki przed parsowaniem, ujawniając prawidłowy DOCTYPE i definicje encji.

Ocena ryzyka

Przetwarzanie spreparowanego pliku XLSX może spowodować atak denial of service przez rozwinięcie encji, a na PHP przed 8.0 lub przy włączonym LIBXML_NOENT umożliwić dostęp do plików lokalnych lub SSRF. Ryzyko dotyczy aplikacji przetwarzających niezaufane pliki XLSX.

Rekomendacja

Zaktualizuj PhpSpreadsheet do wersji 1.30.7, 2.1.19, 2.4.8, 3.10.8 lub 5.10.0 (lub nowszej). Do czasu aktualizacji ogranicz przetwarzanie niezaufanych plików XLSX i unikaj włączania LIBXML_NOENT.

Inne podatności w PhpSpreadsheet

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Prior to 1.30.7, 2.1.19, 2.4.8, 3.10.8, and 5.10.0, XmlScanner::scan in src/PhpSpreadsheet/Reader/Security/XmlScanner.php uses a DOCTYPE detection pattern that accounts for NUL-byte interleaving but not ISO-2022 escape sequences in XLSX XML parts. The escape sequences prevent the scanner from matching the declaration, and XML charset normalization then removes the escape bytes before parsing, exposing a valid DOCTYPE and entity definitions. Processing an attacker-controlled XLSX can therefore cause entity-expansion denial of service on supported PHP versions and can permit local file access or SSRF on PHP before 8.0 or when LIBXML_NOENT is enabled. This issue is fixed in versions 1.30.7, 2.1.19, 2.4.8, 3.10.8, and 5.10.0.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS