Katalog CVE

CVE-2026-106563

ŚrednieCVSS 5.3
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.22%

Percentyl 12 - wyżej niż 12% wszystkich znanych CVE

Streszczenie

W Backstage przed wersją 0.21.8 pakiet @backstage/plugin-kubernetes-backend jest podatny na nieprawidłową walidację encji w przestarzałym endpointcie usług Kubernetes. Uwierzytelniony użytkownik z uprawnieniami odczytu Kubernetes może uzyskać dostęp do danych obciążeń Kubernetes poza zamierzonym zakresem, dostarczając spreparowane dane encji do przestarzałego endpointu usług. Ekspozycja ogranicza się do dostępu tylko do odczytu metadanych obiektów Kubernetes w skonfigurowanych klastrach. Problem naprawiono w wersji 0.21.8.

Ocena ryzyka

Uwierzytelniony użytkownik może uzyskać nieautoryzowany dostęp do metadanych obiektów Kubernetes w skonfigurowanych klastrach, co może ujawnić informacje o infrastrukturze.

Rekomendacja

Zaktualizuj @backstage/plugin-kubernetes-backend do wersji 0.21.8 lub nowszej. Rozważ wyłączenie przestarzałego endpointu usług Kubernetes.

Powiązane podatności

Oryginalny opis (angielski, źródło NVD)

Backstage is an open framework for building developer portals. Prior to 0.21.8, the @backstage/plugin-kubernetes-backend package is affected by improper entity validation in deprecated kubernetes services endpoint. An authenticated user with Kubernetes read permissions could access Kubernetes workload data beyond their intended scope by supplying crafted entity data to the deprecated services endpoint. The exposure is limited to read-only access to Kubernetes object metadata across configured clusters. This issue is fixed in version 0.21.8.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS