Katalog CVE

CVE-2025-66206

ŚrednieCVSS 6.8
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.34%

Percentyl 26 - wyżej niż 26% wszystkich znanych CVE

Streszczenie

Frappe przed wersjami 15.86.0 i 14.99.2 był podatny na ataki path traversal, umożliwiające pobranie niektórych plików z serwera przy znanej pełnej ścieżce. Witryny hostowane na Frappe Cloud oraz za reverse proxy (np. NGINX) nie są dotknięte; problem dotyczy głównie bezpośredniego użycia werkzeug/gunicorn.

Ocena ryzyka

Możliwy nieautoryzowany odczyt plików z serwera, co może prowadzić do ujawnienia danych wrażliwych lub konfiguracji. Ryzyko dotyczy głównie instalacji bez reverse proxy.

Rekomendacja

Zaktualizuj Frappe do wersji 15.86.0 lub 14.99.2. Alternatywnie wdróż reverse proxy (np. NGINX) przed aplikacją, aby ograniczyć podatność.

Inne podatności w Frappe

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

Frappe is a full-stack web application framework. Prior to 15.86.0 and 14.99.2, certain requests were vulnerable to path traversal attacks, wherein some files from the server could be retrieved if the full path was known. Sites hosted on Frappe Cloud, and even other setups that are behind a reverse proxy like NGINX are unaffected. This would mainly affect someone directly using werkzeug/gunicorn. In those cases, either an upgrade or changing the setup to use a reverse proxy is recommended. This vulnerability is fixed in 15.86.0 and 14.99.2.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS