Katalog CVE

CVE-2025-64726

WysokieCVSS 7.3
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.16%

Percentyl 5 - wyżej niż 5% wszystkich znanych CVE

Streszczenie

Socket Firewall w wersjach binarnych przed 0.15.5 jest podatny na wykonanie dowolnego kodu, gdy jest uruchamiany w niezaufanych katalogach projektów. Atakujący może umieścić złośliwy plik `.sfw.config`, który ustawia zmienną `NODE_OPTIONS` z dyrektywą `--require`, co pozwala na wykonanie złośliwego kodu JavaScript przed inicjalizacją mechanizmów bezpieczeństwa narzędzia.

Ocena ryzyka

Organizacja może zostać zainfekowana złośliwym kodem, jeśli deweloper uruchomi Socket Firewall w niezaufanym projekcie, co może prowadzić do obejścia ochrony i kompromitacji środowiska deweloperskiego.

Rekomendacja

Zaktualizuj Socket Firewall do wersji 0.15.5 lub nowszej. Jeśli nie jest to możliwe, unikaj uruchamiania narzędzia w niezaufanych katalogach projektów i przed uruchomieniem sprawdzaj pliki `.sfw.config` oraz `.env.local` pod kątem podejrzanych definicji zmiennych środowiskowych, zwłaszcza `NODE_OPTIONS`.

Inne podatności w Socket Firewall

Oryginalny opis (angielski, źródło NVD)

Socket Firewall is an HTTP/HTTPS proxy server that intercepts package manager requests and enforces security policies by blocking dangerous packages. Socket Firewall binary versions (separate from installers) prior to 0.15.5 are vulnerable to arbitrary code execution when run in untrusted project directories. The vulnerability allows an attacker to execute arbitrary code by placing a malicious `.sfw.config` file in a project directory. When a developer runs Socket Firewall commands (e.g., `sfw npm install`) in that directory, the tool loads the `.sfw.config` file and populates environment variables directly into the Node.js process. An attacker can exploit this by setting `NODE_OPTIONS` with a `--require` directive to execute malicious JavaScript code before Socket Firewall's security controls are initialized, effectively bypassing the tool's malicious package detection. The attack vector is indirect and requires a developer to install dependencies for an untrusted project and execute a command within the context of the untrusted project. The vulnerability has been patched in Socket Firewall version 0.15.5. Users should upgrade to version 0.15.5 or later. The fix isolates configuration file values from subprocess environments. Look at `sfw --version` for version information. If users rely on the recommended installation mechanism (e.g. global installation via `npm install -g sfw`) then no workaround is necessary. This wrapper package automatically ensures that users are running the latest version of Socket Firewall. Users who have manually installed the binary and cannot immediately upgrade should avoid running Socket Firewall in untrusted project directories. Before running Socket Firewall in any new project, inspect `.sfw.config` and `.env.local` files for suspicious `NODE_OPTIONS` or other environment variable definitions that reference local files.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS