CVE-2025-62519
WysokieCVSS 7.2Prawdopodobieństwo exploitacji (EPSS)
Podwyższone ryzykoPercentyl 53 - wyżej niż 53% wszystkich znanych CVE
Streszczenie
phpMyFAQ to otwartoźródłowa aplikacja webowa FAQ. W wersjach przed 4.0.14 występuje podatność SQL injection w głównej funkcji aktualizacji konfiguracji, umożliwiająca uprzywilejowanemu użytkownikowi z uprawnieniami 'Configuration Edit' wykonanie dowolnych poleceń SQL.
Ocena ryzyka
Udana eksploatacja może prowadzić do pełnego przejęcia bazy danych, w tym odczytu, modyfikacji lub usunięcia wszystkich danych, a także potencjalnego zdalnego wykonania kodu w zależności od konfiguracji bazy danych.
Rekomendacja
Zaktualizuj phpMyFAQ do wersji 4.0.14 lub nowszej.
Inne podatności w phpMyFAQ
Zobacz wszystkie- CVE-2026-56736Wysokie
phpMyFAQ to open source'owa aplikacja webowa FAQ. Podatność typu stored XSS w wersjach przed 4.2.0-alpha pozwala nieuwierzytelnionemu użytkownikowi (lub użytkownikowi o niskich uprawnieniach) na wstrzyknięcie dowolnego kodu JavaScript, który wykonuje się w przeglądarce administratora podczas przeglądania lub edycji wpisu FAQ. Prowadzi to do przejęcia konta administratora poprzez kradzież sesji.
- CVE-2026-57994Średnie
Podatność w phpMyFAQ przed wersją 4.1.5 pozwala nieuwierzytelnionym atakującym na odczyt nieaktywnych (wersje robocze lub tylko do recenzji) treści FAQ poprzez niespójne filtrowanie w publicznych punktach końcowych API.
- CVE-2026-57961Niskie
phpMyFAQ przed wersją 4.1.5 zawiera podatność na ścieżkowy atak typu path traversal w funkcji concatenatePaths() w pliku Wrapper.php. Użytkownik z uprawnieniami do edycji FAQ może przechowywać HTML z spreparowanymi ścieżkami obrazów, które są przetwarzane podczas generowania PDF. Brak kanonizacji ścieżki i walidacji ograniczenia do katalogu głównego może pozwolić na odczyt plików poza zamierzonym katalogiem treści.
- CVE-2017-15808Wysokie
W phpMyFaq przed wersją 2.9.9 występuje podatność typu CSRF w pliku admin/ajax.config.php.
- CVE-2017-15735Wysokie
W phpMyFAQ przed wersją 2.9.9 występuje podatność na Cross-Site Request Forgery (CSRF), która umożliwia modyfikację glosariusza.
- CVE-2017-15734Wysokie
W phpMyFAQ przed wersją 2.9.9 występuje podatność na atak Cross-Site Request Forgery (CSRF) w pliku admin/stat.main.php.
- CVE-2017-15733Wysokie
W phpMyFAQ przed wersją 2.9.9 występuje podatność na atak Cross-Site Request Forgery (CSRF) w plikach admin/ajax.attachment.php oraz admin/att.main.php.
- CVE-2017-15732Wysokie
W phpMyFAQ przed wersją 2.9.9 występuje podatność typu Cross-Site Request Forgery (CSRF) w pliku admin/news.php.
- CVE-2017-15731Wysokie
W phpMyFAQ przed wersją 2.9.9 występuje podatność typu Cross-Site Request Forgery (CSRF) w pliku admin/stat.adminlog.php.
- CVE-2017-15730Wysokie
W phpMyFAQ przed wersją 2.9.9 występuje podatność typu Cross-Site Request Forgery (CSRF) w pliku admin/stat.ratings.php.
Oryginalny opis (angielski, źródło NVD)
phpMyFAQ is an open source FAQ web application. Prior to version 4.0.14, an authenticated SQL injection vulnerability in the main configuration update functionality of phpMyFAQ allows a privileged user with 'Configuration Edit' permissions to execute arbitrary SQL commands. Successful exploitation can lead to a full compromise of the database, including reading, modifying, or deleting all data, as well as potential remote code execution depending on the database configuration. This issue has been patched in version 4.0.14.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

